windows taking its time to restart/shutdown

Discussion in 'Windows Desktop Systems' started by dominic02, Sep 26, 2003.

  1. dominic02

    dominic02 Guest

    when i go to either shut down or restart it takes a while for my computer to actually start to shutdown. It just sits there as if i hadn't told it to shutdown or restart. Then after a minute or two programs start shutting down and than windows shutsdown. Does ayone know what could be causing this?
     
  2. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    Welcome to the forums dominic02. :)

    For starters have a look over here. Let us know if you find anything or not.

    If not let us know a little more about your setup.
     
  3. dominic02

    dominic02 Guest

    Heh yea i always forget to say what i've got.
    I've got a 2.8ghz p4b, 512mb ram, 64mb ATI radeon 9000 running windows xp professional.

    That site looks great, haven't gotten a chance to go through it yet though.

    Thanx for the reply.
     
  4. FourDiceS

    FourDiceS Guest

    I've had this problem before where I could wait up to 5 minutes for my pc to Shut down. If you have a Via chipset Install the latest 4in1 drivers and it will fix your problem.

    Good luck
     
  5. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Messages:
    5,518
    Location:
    England
    try this

    open regedit

    Hkey_Local_Machine/system/controlset001/control

    then change waittokillservicetimeout to a lower number, that way xp will wait less time before killing services as it shuts down


    theres also a AutoEndTasks (change to 1) setting in HKEY_CURRENT_USER\Control Panel\Desktop
    This forces any task, that does not respond to the shutdown, to end.
    You can also change Value of WaitToKillAppTimeout The default: is 20000 milliseconds (20 seconds). If the user process does not end by this time, AutoEndTasks is invoked.

    can try all at once or one of them at a time, whatever

    always backup regkeys before changing them
     
  6. Lukas

    Lukas Real Name No Gimmicks

    Messages:
    421
    How about using bootvis to improve the shutdown speed?

    And check if the pagefile is beeing cleared on shutdown:
    Administrative Tools -> Local Security Policy -> Security Settings -> Local Policies -> Security Options -> Shutdown: Clear virtual memory pagefile.


    Greetz

    Lukas
     
  7. Lukas

    Lukas Real Name No Gimmicks

    Messages:
    421
    I don't know the link to BootVis by heart, so here it is.


    Greetz,

    Lukas
     
  8. FourDiceS

    FourDiceS Guest

    You should really try installing the right via drivers first.