Win XP PRO Install problems

Discussion in 'Windows Desktop Systems' started by mazspeed@redshi, Apr 30, 2003.

  1. Ok, I have a bit of a weird problem, but at this point I'm just going to forget about redoing my update. Here is what I did. I put the Win XP Pro update disk in as I sometimes do to sort of "refresh" my system up a bit. What happened is my system would hang at the same point during the reinstall. It would hang up at the "system rebooting phase" where it would hang up where the bars at the bottom say it's restarting and it does nothing. Ok, so it won't work right now, big deal, but now everytime I restart the system, it wants me to choose which location to go into, either the "Windows Pro, or Windows Pro setup. I want to get rid of the set up part. How do I do this?

    Thanks again all for listing to me ramble :p

    Cheers
    Mike
     
  2. Shamus MacNoob

    Shamus MacNoob Moderator Political User

    Messages:
    4,199
    Location:
    L'Ile Perrot Quebec
    edit your boot.ini


    should look like this


    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /FASTDETECT
     
  3. Geffy

    Geffy Moderator Folding Team

    Messages:
    7,805
    Location:
    United Kingdom
    an improperly cooled CPU can cause this as well, if you have moved the heatsink around in a past few days or whatever then you will need to remove it, the thermal paste, then apply new paste and replace the heatsink, for instructions search the threads there are a few about Thermal Paste
     
  4. Hey Kermit, where is the boot.ini file at? I did a serch and it didn't come up with anything..

    Thanks again

    Cheers
    Mike
     
  5. sboulema

    sboulema Moderator

    Messages:
    2,846
    Location:
    Amstelveen, The Netherlands
    its located in the root of your bootdisk, so it will be at c:\boot.ini its a hidden systemfile
     
  6. Ok guys.. Here is my boot file.

    [Boot Loader]
    Timeout=5
    Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT
    [Operating Systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect


    My harddrive is on "G" and not "C" like a normal one. I did the fix, and it still has a choice, only now the choice is "Windows Default" and "Windows Pro" I don't want to mess this up, and I needed to let you guys know my drive is a "G" and not a "C" if that makes any difference

    Thanks again guys for your help..

    Cheers
    Mike
     
  7. pazzer2002

    pazzer2002 Guest

    k, why is your xp boot drive G: ??? if it's a physically different HDD then u'll need to use a different drive mapping to locate it's boot data, like kermit, my boot.ini is like:

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

    to start with, set ur timeout value to 30 odd, otherwise u'll run to your keyboard tryin to select a different boot option with a cup of boiling coffee in ur hand, cos uve only got 5 secs to do it in. unless ur keyboard needs a wash that is....

    the OS u've got in ur boot.ini is in the first partition of the first HDD, that is c:\ presumably, but how many OS's u got installed? just the one? the thing is, XP sorts the drives in a different order when ur lookin in my computer, u gotta look at the drive mapping of the drive, which is how the boot.ini refrences the drives.
    take note:

    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    is equal to your c:\windows (1st HDD, 1st partition)
    ________________________________________

    now if windows is installed on the second partition, and u wanna boot from there, do this:

    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    which is equal to d:\windows (1st HDD, 2nd partition)
    ________________________________________

    if ur bootin from a second HDD, u need to change the drive number rather than the partition number:

    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
    equates to e:\windows, if this is the second disk in the system drive mapping, workin on the basis that this disk is after the two i wrote about above.

    i need to know exactly why ur drive is G: drive.......
    is it a second hard drive?
    is it just G: in windows, but a partition on your HDD?

    we gotta kno. sorry its such an arse. :rolleyes:
     
  8. Hey Pazzer. I forgot to do the changing of the drive letters till it was to late. I have 2 hard drives but only use one and it's not partitioned at all. The other hard drive is just a backup for programs, files pictures that sort of thing. My back up funny enough is drive "C" and my normal bootup is drive "G". That's my little screw up, but I can live with it. I guess at this point I need something to just copy and paste to my boot.ini screen. I had the "5" put in for quicker boot times, and since it's not a partition it just boots a little quicker or so it seems. Is there any other info you need?

    Thanks so much for your help, Ill be on the board all day and night..

    Thanks again
    Mike
     
  9. bkrepfle

    bkrepfle Guest

    well, it looks like what you need to do to fix this is to get rid of

    C:\$WIN_NT$.~BT\BOOTSECT.DAT from the


    Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT line and replace it with:


    Default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

    The fact that your showing C: under your default is leading me to believe that that is the setup prompt loading on your computer. You said before your drive is G:. If you do this change, you should not have the boot prompt anymore.
     
  10. Hey bkrepfle, and everyone else, that was the fix.. You guys were great, thank you so much :happy:

    Cheers
    Mike
     
  11. pazzer2002

    pazzer2002 Guest

    send us some money when ur rich. unless u allready are, in which case, email me immediatley!

    lol

    pazzer