Where are my icons?

Discussion in 'Desktop Customisation' started by sphere, Mar 6, 2003.

  1. sphere

    sphere Guest

    Since I installed XP Pro I haven't been able to see a few icons (Printers and Faxes, Control Panel, Connect To (old icon)) on my machine. I'm guessing it has to do with a corrupt installation, because SP1 didn't fix it and replacing the shell32.dll with someone elses didn't fix it either. I've also tried deleting the icon cache dll file, replacing the .cpl files and running a sfc scan but that hasn't helped. There's a screenshot below to help you guys understand.

    Any help would be appreciated.
     
  2. zyfos

    zyfos Resurrected

    Messages:
    236
    I have an XP Power Toys package that has a TweakUI in it. It has an option to "Rebuild Icons". Xteq might have a similar feature in it, but I'm not sure.
     
  3. sphere

    sphere Guest

    Tried that already. Didn't work.
     
  4. zyfos

    zyfos Resurrected

    Messages:
    236
    Did it do this with other skins too?
     
  5. sphere

    sphere Guest

    Yes, all skins.
     
  6. yoyo

    yoyo _________________

    Messages:
    1,557
    You could check the following registry keys. They should read:

    printer+faxes
    HKEY_CLASSES_ROOT\CLSID\ {2227A280-3AEA-1069-A2DE-08002B30309D}\ DefaultIcon = %SystemRoot%\System32\shell32.dll,-138

    controlpanel
    HKEY_CLASSES_ROOT\ CLSID\ {21EC2020-3AEA-1069-A2DD-08002B30309D}\ DefaultIcon = %SystemRoot%\System32\shell32.dll,-137

    and if present

    HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\Windows\ CurrentVersion\ Explorer\ Shell Icons
    @ 37 = %SystemRoot%\System32\shell32.dll,-138
    @ 35 = %SystemRoot%\System32\shell32.dll,-137

    (still searching where the 'connect' icon is located)
     
  7. sphere

    sphere Guest

    Thanks for that info yoyo.

    My settings were different at those locations. I changed them to what you posted and rebooted, but it hasn't fixed the problem.
     
  8. zyfos

    zyfos Resurrected

    Messages:
    236
    Have you redone your icon cache since you changed the reg settings?
    You could always yell loud profanities at the computer and reformat as a last option. :p
     
  9. sphere

    sphere Guest

    Yep, I tried rebuilding the icon cache and rebooting since the change.

    I guess there is no real solution to the problem, other than an install.

    If anyone can fix it I will personally kiss your... :eek: :p
     
  10. JohnnyGreb

    JohnnyGreb Guest

    Have you tried the following?
    Right-click on the start button, go to properties. Then (going from memory, at work atm) Advanced, and there should be a list of what's shown and not shown on the start menu. Most of them should be in there. Select the ones you want to show up.

    -Ryandor
     
  11. yoyo

    yoyo _________________

    Messages:
    1,557
    No real idea at the moment. Also thought of deselecting and reselecting the items from startmenu properties.
    Does the problem occur in every user account?
    Are the icons displayed properly elsewhere?
     
  12. sphere

    sphere Guest

    None of those suggestions worked.

    Ryandor - They are present in the menu, but the icons aren't showing next to the names.

    yoyo - Tried it. It occurs on every account and everywhere there is no icon.
     
  13. zyfos

    zyfos Resurrected

    Messages:
    236
    Do the icons appear in Windows Explorer?
     
  14. sphere

    sphere Guest

    zyfos, no they don't.


    BUT... Guess what! I got them back. Well, sorta.

    I changed my shell32.dll over to the Snow E2 shell and then I used a program called E-Icons to change the icons that weren't working to another icon in the shell32.dll file.

    So it's all good now.