Warcraft3 and Detinators

Discussion in 'PC Gaming' started by Sux, Jan 30, 2003.

  1. Sux

    Sux Guest

    I'm having problems with WC3 and any detinator driver newer than 23.11
    All the others give me greef with the game menu.
    28.32 - 30.82 give just a blank screen with sound
    40.41 - 41.09 give blinking menu buttons.

    The stock standard XP pro vid driver is the only other one that works.
    Anyone else having problems with this game and more resent Det drivers? (the game is patched up to date)
  2. _DM_

    _DM_ OSNN Senior Addict

    i think those are the bug versions. if u wana get rid of the detnators reinstall.
  3. Sux

    Sux Guest

    Bug versions?
    All of them work fine on every other game.
    I did these tests with a spare harddrive I had with a fresh install of XP pro with DirectX8.1 and all the hardware drivers up to date.
    Then I went though my detinator colection(7 in total) from oldest to newest uninstalling each one I tried ,as I went.
    It was interesting that the problem changed with the 40.xx ones.
  4. MyJelleo

    MyJelleo OSNN Junior Addict

    Yeah, I'm having the same problem. My warcraft either freezes or completely crashes my computer if I use any of the newer drivers other than the ones that came in the box.
  5. Sux

    Sux Guest

    In my case it has never frozen or crashed, the sound still goes in the back ground there is just a problem with the button textures
    or no visuals at all ,pressing "esc "always takes it back to desktop
    as it would if it was running properly .
    Is 23.11 the only detinator that works for you too.
    None of the Warcraft sites are any help so it can't be very common.
  6. Sux

    Sux Guest

    Ok I found a solution .
    The game runs by default in Direct3D from another forum I found that if you change the shortcut path from say:

    "C:\program files\Warcraft III\Warcraft III.exe"


    "F:\program files\Warcraft III\Warcraft III.exe" -opengl

    the game runs in openGL mode and in my case the latest Det driver and I susect all the others work fine.
    Hope this is of help to anyone it sure took me a while to get to the bottom of it.
  7. Lion

    Lion Guest

    same error here
    my computer rebooted from the game 2 times and it is very slow to open a game online even in my computer
    Pentium 4 1600 mhz
    128 ram ddr
    tnt 2 with det 42.01
  8. Misfire

    Misfire OSNN Addict

    hmm, tnt2 is a slow card. Try running in -opengl or even software texture and lighting.

    my voodoo 3 couldn't run the game too well.

    now with geforce 4 no problem....... :)
  9. Emeritus

    Emeritus Guest

    I'm running WCIII with 42.86 drivers without a hitch, using a GF4 ti4600. Working great in NFS:HP2 and Rallisport Challenge!

    Anyway, I thought maybe you try the 42.86, after you unistall everything else.