vista home premium remember network passwords after reboot?

Discussion in 'Windows Desktop Systems' started by _kC_, Feb 15, 2007.

  1. _kC_

    _kC_ Moderator

    Messages:
    514
    hi, just built a new media center for my daughters bedroom, and decided to use vista home premium on it.

    in my home ive 3 XP pro machines and a MCE 2005 machine, which all remember network passwords..
    so built the new machine, installed vista, nvidia drivers, TV card drivers etc.. all going well..
    now came to mapping network drives and shared libraries etc.. up popped the box
    USERNAME:
    PASSWORD:
    and a tick box (remember password)

    so ive created a new user on my network so my daughter can have read only access. after entering user/pass and ticking remember password, all is great.. until i reboot then it says mapped drives couldnt be reconnected, and any shares i attempt it prompts for a user/pass again! (acting like an xp home machine)

    do i need to get ultimate to be able to remember network passwords? and why the hell is the option to remember passwords in home premium, but after a reboot it doesnt remember?
    is home premium designed this way? to act like xp home and require passwords after a reboot?

    this is a totally fresh instal, only finished building the tower 2hrs ago, and all thats been done is graphics & tv card drivers..
     
  2. kop48

    kop48 OSNN Addict

    Messages:
    209
    Try to see if 'simple file sharing' is turned on in folder options.
     
  3. _kC_

    _kC_ Moderator

    Messages:
    514
    hi,
    thanks for the help.. i had a look in folder options, but there wasnt a "use simple file sharing" like xp
    there was a "use sharing wizard" which was enabled

    i tried disabling it.. went on the network, entered user/pass and ticked "remember"
    access ok, could open music/pics etc..

    rebooted, but it prompts for user/pass again:rolleyes:


    within user accounts, you can manage network passwords..
    but the ability to store windows logon credentials is greyed out?

    i cant believe m$ have done this. i was under the impression that "home premium" should be pretty much the same as "xp mce 2005"
    but NO! just to be able to save network passwords id need the ultimate edition:/

    why on earth does home premium have the box "remember passwords" if it cant actually remember a network password...
     
    Last edited: Feb 15, 2007
  4. American Zombie

    American Zombie Moderator Staff Member Political User

    Messages:
    2,932
    Location:
    Seattle
    Have you tried typing control userpasswords2 in the search box then in the window that opens go to the advanced tab > manage passwords?
     
  5. _kC_

    _kC_ Moderator

    Messages:
    514
    brings you to the same window as controlpanel/user accounts/manage network passwords

    sneaky by m$:mad:

    vista home premium totaly useless to me now
     
  6. American Zombie

    American Zombie Moderator Staff Member Political User

    Messages:
    2,932
    Location:
    Seattle
    You can not use Local Security Policy in Premium so you would have to edit a registry entry if you can find out which one you need to edit.
     
  7. Aprox

    Aprox Moderator Political User

    Messages:
    2,737
    Location:
    California, USA
    I have the same issue with mapped Samba network drives. I'm using Vista Business... which you would think would definitely support the feature. So I think its just a bug or something we have overlooked.
     
  8. _kC_

    _kC_ Moderator

    Messages:
    514
    wow..
    aint vista just awesome

    but never mind if important things dont work, because it now has pretty eye candy ;)
     
  9. madmatt

    madmatt Bow Down to the King Political User

    Messages:
    13,312
    Location:
    New York
    Vista Home Premium (as it was with MCE 2005 and earlier) is not designed for this purpose. I am using Ultimate on my production box and Business on my test box and I have no problems whatsoever with network mappings.

    http://www.microsoft.com/windows/products/windowsvista/editions/choose.mspx

    However, make sure "Everyone" has full permission to the Share and the folder itself. If the "Reconnect at logon" option isn't working, create a batch file to run on startup to re-map the drive.
     
  10. erys81

    erys81 OSNN One Post Wonder

    Messages:
    1
    You need to utillize Vista's UAC (user account control) tool.

    Click on the start butto, type "User Accounts", and press Enter.
    Click Manage network passwords on the side menu.
    Select 'Add' for this problem
    Fill out the 'Stored Credential Properties' screen and click OK.

    Hope this helps.
     
  11. ken2johnson

    ken2johnson OSNN One Post Wonder

    Messages:
    1
    I had the same trouble in Vista Home Premium. I tried all the "Store network password" options I could find and nothing worked. So, this was my solution. I created a vbscript that connects a network share and placed it in my startup folder.

    You can do the same thing. Just create a text file in notepad, paste the code below into it. Then change the server, share, username, and password information. Don't delete any of the commas or quotation marks. They are all needed. Save it to your startup folder. In Vista your startup folder is buried deep. Mine is located here: C:\Users\Ken\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
    Yours should be the same except for the name "Ken" of course. Here's the code:

    Set objNetwork = CreateObject("WScript.Network")
    objNetwork.MapNetworkDrive "Z:", "\\server\share", , "username", "password"


    You can add more mapped drives by copying that last line as many times as you need.
     
  12. LeMMiNGS

    LeMMiNGS OSNN One Post Wonder

    Messages:
    3
    Hi, I was having the same issue as you, and I was using Vista Ultimate 64bits,

    I got it to work by doing this:

    1 - Reboot the computer
    2 - After you log it will say your mapped drive couldn't be connected and stuff.... ok
    3 - Go into Control Pannel, User Accounts, Network Passwords, and add the \\server\share, with the username & password you want
    4 - Open My Computer, and access your mapped drive
    5 - Reboot the computer

    After this, all the time windows boots up it shall reconnect without that f*cking message again :D

    Notice: Its important to do the steps as described because if you only add the server password into the Network Passwords but you don't use it, windows will not store it and will not remember the password the next time you boot.


    Enjoy!! :D
     
  13. prashsoni9

    prashsoni9 OSNN One Post Wonder

    Messages:
    1
    Thnx for the fix. It worked for me the 2nd time till I realised that I had to name the file with the "server" and type .vbs as extension. Thnx a lot. Was getting afraid at the thought to spend more on upgrading to Business :)
     
    Last edited by a moderator: Aug 9, 2008