Visiontek Xtasy GeForce4 Ti4600 ---> FREEZES MY PC...Please Help

Discussion in 'Graphics Cards' started by Cannibal Corpse, Jul 4, 2002.

  1. Hi All,

    I have just got a Visiontek Xtasy GeForce4 Ti4600, and I am playing WARCRAFT III, and for no reason after a couple of minutes the game (and the system) freezes, so I have to reboot.

    My system specs:

    Intel PIII-850MHz
    1GB PC-133 SDRAM RAM
    Abit BX6-Rev 2.01 MoBo
    Visiontek Xtasy GeForce4 Ti4600
    40GB HDD (Maxtor)

    I just replaced Visiontek Xtasy GeForce4 Ti4600, with my good old Prophet 3D Ultra (GeForce 2 Ultra, 64MB)

    I have NOT overclocked my system, nor this new video card and my PC Case is open, so the OVERHEATING is NOT an issue. I am using the latest official nVIDIA drivers.

    Any help would be greatly appreciated.
     
  2. Gary Pandher

    Gary Pandher Moderator

    Messages:
    884
    ur using win XP?
     
  3. I am using XP Pro
     
  4. GoNz0

    GoNz0 NTFS Stoner

    Messages:
    2,781
    Location:
    the year 2525
    those cards are power hungry. 1st i would try the latest drivers if you ain't got them already.
    Bios update is another option.

    btw how big is the PSU ?
     
  5. Mine is a 250W, but I am upgrading 350W
     
  6. I need to upgrad my POWER SUPPLY to a 300 or 350W.
     
  7. GoNz0

    GoNz0 NTFS Stoner

    Messages:
    2,781
    Location:
    the year 2525
    yup should help.
     
  8. The strange thing is that my system does NOT Freeze in normal Windows operations (reading e-mails, browsing the Internet, etc.)
     
  9. GoNz0

    GoNz0 NTFS Stoner

    Messages:
    2,781
    Location:
    the year 2525
    no my mate had the same, top spec system and a 300w PSU.. in a intensive game like medal of honor his pc would lock.. games demand everything from a pc nowdays & then some.