Virtual Memory Settings - defaulting to 0Mb?

Discussion in 'Windows Desktop Systems' started by peddierd, Dec 18, 2001.

  1. peddierd

    peddierd Guest

    I'm having problems setting a virtual memory paging size - even if I leave it to Windows to set the size it still reverts to 0Mb on the Advanced Tab page - when I go into the system settings and try and change it, it has the setiings I tried manually - min 190Mb - Max 300Mb. Re-booting each time!

    When logging in as the administrator (or any other user) it hangs until I pres Ctrl/alt/del and loads my settings as normal. When I log on, occasionally a window pops up telling me about the memory paging size and loads as normal.

    Any help would be appreciated guys.

    standalone/Jetway 867AS motherboard/Athlon 1100Mhz processor/256Mb ram
     
  2. Lonman

    Lonman Bleh!

    Messages:
    2,642
    Also, when you make your "manual settings" changes, be sure to hit the "set" button, otherwise it won't take.
     
  3. NaMcO

    NaMcO Guest

    Hello,

    Do you think that with 768M i can disable my pagefile safely ?
    Will windows ACTUALLY perform better without one or does it work better with it enabled ? Does anyone have any real experience with this issue ?

    Thanks,

    NaMcO
     
  4. NaMcO

    NaMcO Guest

    Yeah, exactly what i was thinking...some apps NEED pagefiles to work correctly (they're probably expecting it as a part of the OS as it comes enabled by default). Besides that it should be hardly noticeable the increase in performance....oh well, indeed:

    Better safe than sorry. Let it live ;)
     
  5. peddierd

    peddierd Guest

    I truly appreciate the reply from APK - thanks you.

    My system is a new-build - 40 gig hard drive - newly formatted with only XP operating system, Office 2000 and my virus software on the drive.

    Thanks again - any other suggestions.

    Richard
     
  6. ZipTriX

    ZipTriX Guest

    I set my initial size to 50 megs and max to 3000 mb. I have 1024 mb of ram.
     
  7. Lonman

    Lonman Bleh!

    Messages:
    2,642
    What's the message you're getting?

    You might try setting your initial size to zero. I guess if XP insists on zero, you might play along and see if it helps.
     
  8. gothic

    gothic LinuXPert

    Messages:
    453
    Location:
    Cornwall Nr. England
    There are applications that need a pagefile. I run with 512 megs but found that a pagefile.sys of about 160 megs was required. I overcame the same problem as yours by hacking the registry manually:
    goto-
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session Manager\Memory Management\

    you should have a string value entry something like

    PagingFiles REG_MULTI_SZ C:\pagefilesys ?? ???

    where the ??? are numericals

    change this value to whatever you feel you need as a paging file, (mine reads 160 200) and check to see if they are the same in the other ControlSets
    (ControlSet002, ControlSet003 etc.)
    Good luck.
     
  9. Bytes Back

    Bytes Back Ex Police Chief

    Messages:
    1,383
    Location:
    Kernow
    So why does the pagefile have to be contigious ?

    If it's on the same drive as xp then as its constantly changing size then surely it must become fragmented.

    Or have i missed something ?
     
  10. Bytes Back

    Bytes Back Ex Police Chief

    Messages:
    1,383
    Location:
    Kernow
    Whoops !!!