USB support not installed

Discussion in 'General Hardware' started by Mubbers, Apr 2, 2004.

  1. Mubbers

    Mubbers Shoot! Political User

    USB, Ethternet & SM Bus support not enabled

    Another wierd issue:

    OK so I'm no expert (yet) at building PCs! For some reason USB and Ethernet support was not enabled on my mobo either by facotry or during XPP loadup (I don't know which) anyway this explains why I couldn't install a USB printer.

    Also SM Bus support not enabled - important?

    So what's the problem you say?

    Why the heck then did my USB mouse work? eh :confused:

    Could this be anything to do with the issue here:
  2. ming

    ming OSNN Advanced

    Which mobo are you using? From what I know, some mobo comes with a utility disc so that you can install drivers for the chipset and various onboard components.

    Regarding your printer, you need to install the printer drivers before you switch it on/connect it to your pc. I have no idea why that is coz I always connect it to the pc and let Windows detect the hardware first.
  3. Mubbers

    Mubbers Shoot! Political User

    Yes! I thought (durrr) that the utility disk was just some "nice to have" programmes! And seeing as the PC worked fine I didn't bother until now....

    Well anyway the printer didn't work coz the USB drivers weren't loaded (it works now) and the USB mouse did work because BIOS support for legacy USB mouse and keyboard was enabled.

    Gosh I'm learning some stuff today :eek:

    MOBO = i865 P4P800 (ASUS)
  4. plex

    plex OSNN Junior Addict

    while you're at it you might as well open up Control Panels
    then System
    then click on the "Hardware" tab
    click "Device Manager"
    this will tell you what else you're missing drivers for.
    anything with an "!" (exclamation mark) in a yellow circle has a problem.