USB Hud??

Discussion in 'General Hardware' started by tinymonkey, Jun 27, 2002.

  1. tinymonkey

    tinymonkey OSNN Addict

    Messages:
    190
    I got a four port USB hud and when I hook something up to it it gives me an error and says 'this device needs more power to run' or something like that. Is there anything I can do, or is the hud just shit??
     
  2. xsk8zerox

    xsk8zerox Moderator

    Messages:
    746
    Location:
    Philly
    Looks like you need a new psu
     
  3. Taurus

    Taurus hardware monkey

    Messages:
    3,206
    Location:
    Sacramento, CA
    you usb HUB should have came with an ac power adapter that plugs into the wall... so it can supply enough power for the extra devices. the usb port on your computer can only put out so many milliamps. it has nothing to do with your computer's power supply.
     
  4. Taurus

    Taurus hardware monkey

    Messages:
    3,206
    Location:
    Sacramento, CA
    true...

    so, tiny... where you at...
     
  5. tinymonkey

    tinymonkey OSNN Addict

    Messages:
    190
    yea, it came with a power apapter i used that and it still didnt work.....i plug it into a power strip, should I plug it directly into the wall??
     
  6. trebor271075

    trebor271075 Guest

    No I would say the hub is faulty then......

    or it's just a rubbish hub....

    Unless your trying to run 36 USB plug and play hair driers off of it! ;-)
     
  7. tinymonkey

    tinymonkey OSNN Addict

    Messages:
    190
    k, thx ill bring it back and get a new one