USB Help Please

Discussion in 'General Hardware' started by Moon, Feb 3, 2002.

  1. Moon

    Moon Guest

    Hello All .

    I seem to be having a few problems with USB devices on my MSI K7N420 XP Home oem settup.

    Firstly I would really appreciate some info on how the Device manager should look after a succesfull install.

    My USB Host controller and USB Root Hub are shown in a sub tree listed under a Grey triangle named Unknown.

    When I connect a USB Device Joystick and Track IR I get the detect new hardware box come up.

    The New hardware Wizard box comes up and I hit the search automaticaly option.

    After a search I get the error box Windows cannot find the software for this device.

    The same happens if I point the Wizard at the Driver install folder and also the root CD , still no go ?

    I have spoken to Track IR company and they confirm the device does work under XP and should appear as ECT Track IR in Universal serial bus controller

    It does in fact appear under a ambiguas Yellow Question mark - Other Devices and a sub listing Yellow question mark and Yellow exclemation mark - USB Device.

    I have tried to uninstall and re boot , and update driver to no avail.

    I have re installed the latest XP motherboard drivers again to no avail.

    Is my install of XP borked .

    Any advice would be really appreciated as my head is getting very sore from hitting the brick wall.
  2. JJB6486

    JJB6486 Retired Mod Political User

    West Lafayette, IN, USA
    First download the latest driver from the manufacturer's website. Go into the device manager and select the USB IR thing. Click Update Driver and instead of searching for it check that you will manualy search for the driver. Enter into the path the path to the new drivers you downloaded.

  3. Lonman

    Lonman Bleh!

    Definantly a driver issue going on. I'm surprised your USB wasn't picked up correctly during setup. First thing to check is to make sure you have USB support enabled in your bios. I've been to your motherboard's (MSI K7N420) support page and it shows 3 bios updates - the newest being Jan 28, 2002. If you have USB support enabled in your bios, and you can't get the drivers to take, then you may need to update your bios.

    I also notice there's 2 driver packages for your board, the nvidia nForce Unified Driver Package Ver1.0, and the nvidiA nForce System Drivers packages.

    My suggestion is to flash your bios, and then get both the XP driver packs for your board. Hopefully, after you flash your bios, XP will pick right up on your USB and install the drivers for it. Be sure to read the Award Flash BIOS Procedure carefully before you do the flash. Good luck and I hope that takes care of your problem.
    Check out the attachment to see what your USB Root Hub will look (kinda) like when you get it fixed.