Unreal and anope

Discussion in 'PC Gaming' started by Spock7291, Oct 30, 2003.

  1. Spock7291

    Spock7291 Guest

    Sorry you games players, I'm refering to the Unreal IRC software. ;)

    I have recently changed my chatroom from ratbox to Unreal3.2-beta18 and am trying to install the anope1.4.26 services.

    For some reason the services will not connect. Since you seem to have aquired a chatroom, I thought I would ask in here to see if there is anyone available who can help me troubleshoot where I went wrong ...
     
  2. JJB6486

    JJB6486 Retired Mod Political User

    Messages:
    1,207
    Location:
    West Lafayette, IN, USA
  3. Spock7291

    Spock7291 Guest

    It appears that there is a password problem? In the Unrealircd.conf, I have set both the password-connect and the password-receive variable to the same password, so hopefully it cannot be that.
     
  4. Spock7291

    Spock7291 Guest

    OK, time for an update. I now have the services and the server talking to each other, but they are talking giberish.

    I compiled both and everything appears to be working properly until I /join a new channel I want to create and register.

    When I get in the channel I am an OP in the channel as normal.
    I give the command to register the channel, i.e., /ChanServ register #garp testpass test
    When I give the command to register the channel, I get the error, "ChanServ- You must be a channel operator to register the channel."

    Before, the problem was shared equally by both sides in that I had not set the passwords properly. It appears there is still something not connecting here. Now, it looks like it's all on the anope side.

    I don't really want to compile them both without any security at all. Any assistance would be greatly appreciated. I've come too far now to want to go back to ratbox!
     
  5. Spock7291

    Spock7291 Guest

    OK, I now have anope-1.4.26 services talking to Unreal3.2-beta18 ... kinda sorta.

    I compiled both and everything appears to be working properly until I /join a new channel I want to create and register.

    When I get in the channel I am an OP in the channel as normal.
    I give the command to register the channel, i.e., /ChanServ register #garp testpass test
    When I give the command to register the channel, I get the error, "ChanServ- You must be a channel operator to register the channel."

    Before, the problem was shared equally by both sides in that I had not set the passwords properly. It appears there is still something not connecting here. Now, it looks like it's all on the anope side.

    I don't really want to compile them both without any security at all. Any assistance would be greatly appreciated. I've come too far now to want to go back to ratbox!
     
  6. Spock7291

    Spock7291 Guest

    Another update:
    I just upgraded to anope-1.5.8 on someone's recommendation. Have the same problems, even after removing the contents of the services folder before install.

    I'm sure it's something I've done. Wonder how hard I will kick myself when the problem is finally figured out?
     
  7. Spock7291

    Spock7291 Guest

    OK, problem solved. I basically wiped both server and services and did clean, default installs. There was also a problem with the way I had set up the services.conf that was solved by a couple of helpful users.

    I was really getting desparate! I knew it had to be something with the conf file, but don't yet have the experience to be able to find it.

    Thanks to all for their help! Feel free to visit any time. I don't have a large server, so cannot support a large client base (the host only allows 500), but short visits are fine.

    I will be setting up #ServTalk where users will be encouraged to discuss other servers/chatrooms and even set up rendevous to meet and go elsewhere. Since I set the chat server up for educational purposes, I don't expect, or want, a large resident user base, but transient is fine. :D