Unable to allocate memory

Discussion in 'Windows Desktop Systems' started by Adamas, Feb 21, 2005.

  1. Adamas

    Adamas OSNN Junior Addict

    Messages:
    23
    Location:
    200 metres from nowhere
    Hey, can anybody help.... I have an Xp Pro box that keeps on displaying UNABLE TO ALLOCATE MEMORY SIZE 2. This is getting to me as the box has its swap file set to it's max, 2 X 512 Duel DDR chips set in slot 1 & 3, with a 256mb graphics card. Any ideas?

    Thanks in advance - Adamas
     
  2. VenomXt

    VenomXt Blame me for the RAZR's Folding Team

    Messages:
    3,453
    Location:
    Houston, Texas
    google memtest86 run it and tell us if it has any problems (this tests memory)
     
  3. Adamas

    Adamas OSNN Junior Addict

    Messages:
    23
    Location:
    200 metres from nowhere
    Thanks sraycoz, I'm @ work & the box it at home - will run memtest86 and see what happens.
     
  4. VenomXt

    VenomXt Blame me for the RAZR's Folding Team

    Messages:
    3,453
    Location:
    Houston, Texas
    ok keep us posted id run the basic test with mem test if no errors if run extended in this situation after basic (but this takes a while) keep coming back and i will help you as much as i can.
     
  5. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    yeh and since no one else said it then WELCOME to OSNN :D - enjoy your stay....
     
  6. Adamas

    Adamas OSNN Junior Addict

    Messages:
    23
    Location:
    200 metres from nowhere
    Thanks Mainframeguy
     
  7. Adamas

    Adamas OSNN Junior Addict

    Messages:
    23
    Location:
    200 metres from nowhere
    I have run the basic test, no errors, I left the extended test, which is still running. The last I checked there were no errors & 46 passes.
     
  8. Adamas

    Adamas OSNN Junior Addict

    Messages:
    23
    Location:
    200 metres from nowhere
    Memtest finished & no errors! any other ideas?
     
  9. IDLE

    IDLE OSNN Senior Addict

    Messages:
    375
    when does this happne? are you running a program and get this error or are you booting up your PC. try giving yourself some more virtual memory space. see if that helps.

    http://www.rsinc.com/services/techtip.asp?ttid=3346

    found this documnet that said to try this. very good info here on this subject.
     
  10. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    Messages:
    12,332
    Location:
    new york
    are you running a server version of the os? see if this helps

    also, I don't know if this article will help, or even if it's accurate, I just pulled it up from a search...have a look;

    here
     
  11. IDLE

    IDLE OSNN Senior Addict

    Messages:
    375
    same doc as the previous post :laugh: :laugh: :laugh:

    beat ya :lick:
     
  12. VenomXt

    VenomXt Blame me for the RAZR's Folding Team

    Messages:
    3,453
    Location:
    Houston, Texas
    any luck
     
  13. Adamas

    Adamas OSNN Junior Addict

    Messages:
    23
    Location:
    200 metres from nowhere
    Ok, I am using XP pro on a stand alone machine, not a server, at first I thought that the warning was happening when a I was using a graphic intense & Ram hungry program, but this is not the case. The program I was using at the time was Surpac, a 3D mining package, the last time I had just opened FlashMX when it happened.

    I have increased the virtual memory again, but have not had a chance to test it yet – the machine is at my house, where I have no telephone / mobile or network connection (how sad) so sorry if I don’t reply sooner. I am starting to think that it could be a memory fragmentation problem, thanks IDLE, interesting article. Hopefully I will have good news on Monday.
     
  14. Adamas

    Adamas OSNN Junior Addict

    Messages:
    23
    Location:
    200 metres from nowhere
    Ok people, It seems that things are working, I haven't decided what seems to have fixed the problem. Things I did.

    Re-seat the RAM
    Increase switch file
    Update the Northbridge chip

    So far I have not had the problem again ..... thankx for all your suggestions.