Ultra DMA Modes

Discussion in 'General Hardware' started by Sage, May 5, 2002.

  1. Sage

    Sage Guest

    I have two HD's 1. maxtor 54098u8 (supports UMDA 100) 2. maxtor 91080D5 (supports UDMA 33). Have all bios options set to auto (only other option is disable) MB is soyo 7vca supports UDMA 33/66 modes, and just installed a new 80 pin UDMA IDE cable (supports UDMA 66). My question is with all things considered why is HD 1 only at Ultra DMA Mode 3 and HD 2 at Ultra DMA Mode 1.

    Ultra DMA Mode - Cycle Time (nanoseconds) - Maximum Transfer Rate (MB/s) - Defining Standard

    Mode 0 240 16.7 ATA/ATAPI-4

    Mode 1 160 25.0 ATA/ATAPI-4

    Mode 2 120 33.3 ATA/ATAPI-4

    Mode 3 90 44.4 ATA/ATAPI-5

    Mode 4 60 66.7 ATA/ATAPI-5

    Mode 5 40 100.0 ATA/ATAPI-6?

    It seems to me that HD 1 should be at UDMA Mode 4 and HD 2 at UDMA Mode 2.
    I have tried everything to correct this, I have looked throught posts relating to this issue but haven't been successful in correcting it. Any insight into this issue would be a big help.
     
  2. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    Just a quick questions before I make a guess judgement, are you getting the DMA modes from the bios, or is that what windows is listing them as. When the comp boots what modes does it list the HD's as being
     
  3. Sage

    Sage Guest

    Modes

    The list of modes in my previous post was taken from a site listing what UDMA modes are (just as reference). On boot my H/D modes are as above H/D 1 UDMA Mode 3 (will support UMDA mode 5, but Mobo only supports up to UDMA mode 4), and H/D 2 UDMA Mode 1 (will support up to UDMA Mode 2). So shouldn't the drives be at the fastest mode supported by the mobo - in this case HD 1 @ mode 4 and HD 2 @ mode 2.
    Note in the Bios there is no setting to choose what UDMA you have - it is just Auto or disable.
     
  4. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    That sounds like a mobo problem or a possible problem with the cable (which I've encountered before due to small tears thanks to the thinness of 80 conductor cable) You might wanna see if there are any bios updates for your mobo and double check to cable for any anomalies
     
  5. gonaads

    gonaads Beware the G-Man Political User Folding Team

  6. Sage

    Sage Guest

    Thanks for the replies

    I've checked over again the items mentioned, cable ok, tried two others, both brand new (orginal maxtor ones) didn't change anything. I'll just have to keep looking.
    Thxs again
     
  7. Sage

    Sage Guest

    Modes

    I just noticed something when I was looking at the info for my drives on the maxtor site. For each drive there are two transfer modes, 1. between the interface, and 2. between media

    DATA TRANSFER RATE:
    To/From Interface (UDMA/66): ............. Up to 66.7 MBs
    To/From Media: ........................... Up to 43.2 MBs

    In XP for both of my drives the UDMA mode listed (in device manager) is the data transfer rate to/fr media. so in this regard both drives are displaying the correct UDMA. Though I would have thought that the to/fr interface mode would be displayed instead.