Turning DMA ON/OFF

Discussion in 'Windows Desktop Systems' started by seeetu, Dec 27, 2004.

  1. seeetu

    seeetu OSNN One Post Wonder

    Messages:
    7
    Hi, I like to know how DMA is turned ON or OFF.....Is there any way to do this or it is managed by the system.Because I have 3HDD(2IDE+1SATA), 1DVD-ROM & 1DVD-RW and ofcourse dual boot 2000+sp4 & XPSP2.From XPSP2 DMA is ON for all drives where as it is OFF for the DVD drives from 2000.I have checked this with "Nero Info Tool".I have not touched anything regarding DMA, just checked and asking here...

    DMA in ON mode gives much faster performance result for copying/burning..


    thanks;- seeetu.
     
  2. Sazar

    Sazar F@H - Is it in you? Staff Member Political User Folding Team

    Messages:
    14,905
    Location:
    Between Austin and Tampa
    should be able to do it through windows/system properties/hardware and then in the list for all devices you should be able to right click on the HDD's and modify properties...

    as with everything else... know what you are doing before clickin on big shiny buttons :cool:
     
  3. dreamliner77

    dreamliner77 The Analog Kid

    Messages:
    4,702
    Location:
    Red Sox Nation
    Some dvd-rom drives will only work in PIO mode if they are a) slave or b) sharing an IDE cable.
     
  4. Mr. K

    Mr. K OSNN Occasional

    Messages:
    75
    Location:
    Ottawa, Canada
    I believe DMA is controlled through modifying the settings of the particular IDE channel.

    In Device Manager (Win+Pause/Break, click Device Manager), browse to your primary and secondary IDE channels (typically listed under 'IDE ATA/ATAPI controllers') and under their properties look at the 'Advanced Settings' tab. You'll have a 'Transfer Mode' menu for each device on the IDE channel; set it to 'DMA if available' and upon reboot it will run at the highest DMA mode it can.

    If you do not have the option to change these, it may be because you have the Intel Application Accelerator installed, which I think automatically maximises your DMA setting (though don't quote me on that).
     
  5. Shamus MacNoob

    Shamus MacNoob Moderator Political User

    Messages:
    4,199
    Location:
    L'Ile Perrot Quebec
    And in alot of cases can be forced in bios setting also.
     
  6. seeetu

    seeetu OSNN One Post Wonder

    Messages:
    7
    I checked all available option under win2000 pro, couldn't find DMA.So, I simply formated it and freshly installed WinXPSP1 and DMA is now ON for all devices.

    BTW, Which one is mostly prefered by XP user.....sp1 or sp2?

    seeetu.
     
  7. the_scotsman

    the_scotsman Shaken Not Stirred

    Messages:
    7
    Most definately SP2!
     
  8. Kr0m

    Kr0m Moderator

    Messages:
    1,390
    Location:
    Turtle Island
    meh, mine are stuck on PIO mode :(
    In the bios the drives are set to auto.
     
  9. Kr0m

    Kr0m Moderator

    Messages:
    1,390
    Location:
    Turtle Island
    whoa, nevermind. I just checked in device manager again and they're (2 drives) set to Ultra DMA mode 4 & 5.
     
  10. jsthrower

    jsthrower OSNN One Post Wonder

    Messages:
    1
    MR K
    Thanks for the mention of the Intel Accelerator in the DMA forumn. I was really confused to find I had No Advanced tabs in my device manager tonight, so I hit the internet to see why. You called it correctly. I installed a 250 G hard drive and was told I should install the Intel Accelerator. I went to All Programs/Intel Accelerator and clicked on it....BOOM...There was all the info that was missing for the device manager. THANKS A MILLION.