Trouble with remote desktop

Discussion in 'Windows Desktop Systems' started by slimco, May 26, 2005.

  1. slimco

    slimco OSNN Junior Addict

    Messages:
    13
    Having trouble connecting to my machine at home. I have followed all the steps from this webpage.

    http://theillustratednetwork.mvps.org/RemoteDesktop/RemoteDesktopSetupandTroubleshooting.html

    Had a friend try to connect to my machine and did so with no problem. I tried to connect to my machine from work and had no luck. I have not changed any settings since my friend connected.

    I used the PortQuery tool from the webpage and got a FILTERED result. I am going to double check the settings tonight when I get home.

    My work machine is running Win2000, while my friends has WinXP Home.
     
  2. Mastershakes

    Mastershakes Moderator

    Messages:
    1,721
    Location:
    Montreal
    Your company's firewall is preventing you from reaching home. Change the default remote desktop port from 3389 to a port that is open on your network.
     
  3. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

  4. lancer

    lancer There is no answer! Political User Folding Team

    Messages:
    3,093
    Location:
    FL, USA
  5. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

  6. lancer

    lancer There is no answer! Political User Folding Team

    Messages:
    3,093
    Location:
    FL, USA
    i know, kinda getting sick of seeing this thread again and again recreated. thought i'd point it out :)
     
  7. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

  8. slimco

    slimco OSNN Junior Addict

    Messages:
    13
    OK, went home and changed the port. Followed the steps in the Microsoft article. Also checked to make sure the new port was listening, which it was.

    Went to try and connect and still no luck. Check PortQuery again on the new port and it still came up as filtered.

    Will try a different port again, till i find one that works.
     
  9. Mastershakes

    Mastershakes Moderator

    Messages:
    1,721
    Location:
    Montreal
    WTF is this 'filtered' crap? .... yes, keep searching. best ones to try first:
    EDIT: Nevermind, I reread your first post :)
    21 (FTP)
    23 (telnet)

    On most networks these are open. The one I'm on now, no.... but I'll be migrating to another network this summer, so it's all good. I have my rdp service listening on port 23 at home.

    If your ISP @ home allows incoming traffic on port 80, let me know. I'll post info on setting up IIS, and tsweb - remote desktop over the web... it's a fire and forget way to connect to home.
     
  10. slimco

    slimco OSNN Junior Addict

    Messages:
    13
    I don't currently have 80 open, but I could. If you could post that info, I'll give it a shot and see what happens.

    Is there a way I could see what ports are open from my office so, instead of trying to guess a port. I'll give the other ports you mentioned a try.
     
  11. Mastershakes

    Mastershakes Moderator

    Messages:
    1,721
    Location:
    Montreal
  12. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    Do you have a router or any firewalls running? and what kind of error are you getting?
     
  13. slimco

    slimco OSNN Junior Addict

    Messages:
    13
    Yes I do have a router, but I have gone into the Router and added my ip address and the port. The port is showing as open and I was able to connect from my friend's machine.

    The message I get is that the client could not connect to the remote computer.
     
  14. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    That router setting would have nothing to do with connecting to your friend's computer. You need to make sure your forwarding the port to your LAN address (just making sure).

    Do you have the windows firewall enabled?
     
  15. slimco

    slimco OSNN Junior Addict

    Messages:
    13
    I am forwarding the IP to my LAN address. I was able to go to my friends computer and connect to my machine with no problem.

    I will double check the windows firewall, but i did go into it and under the exceptions tab make sure remote desktop was checked off.

    It makes me believe it is something with my work because like I said before I made a successfull connection from my friends machine
     
  16. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    Sorry, I thought you were connecting TO his computer. I mis-read. When you are trying to connect from work are you specifying the port as well as the IP?

    like xx.xx.xx.xx:3389

    ^^ only if you changed the port
     
  17. slimco

    slimco OSNN Junior Addict

    Messages:
    13
    Yup, i tried with the port and without the port. Both got the same error message.
     
  18. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    What about any software firewall at work? (Running on your machine.)

    Im running out of ideas
     
    Last edited: May 29, 2005
  19. slimco

    slimco OSNN Junior Addict

    Messages:
    13
    Not that i know of.

    I am running out of ideas as well.
     
  20. ArkadyGr

    ArkadyGr OSNN One Post Wonder

    Messages:
    6
    Does it really matter if the clinet machine is firewalled. I am able to RDP to my home computer from my freinds computer that is connected to a Linksys router with both XP and routers firewall turned on and no ports forwarded or open whatso ever. How ever I am having the same problem as the author of this thread when trying to connect from work. I am behind some sort of proxy i beleive. Is there a way around it?