System Restore Error

Discussion in 'Windows Desktop Systems' started by leedogg, Sep 3, 2003.

  1. leedogg

    leedogg Gojyone kawaiiiiiiii!

    I recently had to do a Repair of XP and now when I try to launch system restore I ge this cryptic message:

    RSTRUI.EXE - Entry Point not found
    The Procedure entry point RemoteAssistancePrepareSystemRestore could not be located in the dynamic link library WINSTA.dll

    Does anybody have any clue what this is and how to fix?

    I wanted to try to restore my pc to a point before I had to do this repair...if thats possible or advisable??

    Appreciate any feedback.
  2. damnyank

    damnyank I WILL NOT FORGET 911

    Petal, Mississippi
    If you did a repair install (loaded XP over a current existing XP) I am not sure if you have to reinstall SP1 or not - that would be my first repair action - to make sure SP1 was installed. If memory serves me correctly the WINSTA.dll is one of the replaced/updated files in SP1!

    I got this fix from microsoft.public.windowsxp.help_and_support - I have never tried it but it fixede this persons problem!

    1. In My Computer, click the Tools menu -> Folder Options.
    2. On the View tab, make sure to check the option "Hide extensions for
    known file types".
    3. Click OK.
    4. Click the Start menu -> Run. Type "%windir%\inf" (Without quotation
    marks) in the Open field. Click OK.
    5. Locate and select the file "sr.inf". Right-click it and then click

    <edit> - I think you will find only the initial restore point - the one that will be made when you get system restore running again. Besides with a repair action - I do not believe any of your previous restore points will be there and if they are still there you will have made wholesale changes to the registry with the repair and they won't work anyway!<edit>
  3. yoyo

    yoyo _________________

    You can not use system restore to go back to a state before you did the repair install. See Microsoft Knowledge Base Article - 301224.

    For the other problem check the version of Winsta.dll. Likely you still have the Service Pack version 5.1.2600.1106 but the service pack isn't installed. Installing it will fix the problem. Otherwise you'll have to expand the file from your Windows XP cd.
  4. leedogg

    leedogg Gojyone kawaiiiiiiii!

    OMG how could I forget the service pack! Trying to remember all the things that need to be patched/upgraded and windows update being down isnt helping...sigh. DamnYank's instructions worked to the T. Thanks man!!! Thanks for the extra info yoyo. OK no restores before the repair. Thats ok. I'm just glad the repair worked. Ran Ghost for the first time and it really did a number on my boot files....suffice to say I was getting "OS not detected" on bootup :(