SVChost problem

Discussion in 'Windows Desktop Systems' started by bastupungen, Mar 23, 2003.

  1. bastupungen

    bastupungen Guest

    I have an extremly annoying problem with the SVCHOST files...
    When i start the computer it will run extremly fine until i do anything that tries to connect to the internet. then the computer goes extremly slow and the page i try to enter wont come up. then 20 sec later the page will come up and the comp will run fine...
    i have identified the problem to SVCHOST... when i start anything connected with the internet then SVChost (network services) will use 99% of my system resouces... for 20 seconds...
    I can quit that process and the comp will run fine but i have read that SVCHOST is an very important program and i dont think its too smart to shut it off... anyways..
    have you guys heard of this before? is there and fix anywhere maybe? ...
    im using XP pro...
  2. Kevin Ar18

    Kevin Ar18 OSNN Senior Addict

    Have you run adaware on your system since it started?
  3. zyfos

    zyfos Resurrected

    Go into Adminsitrative Tools and open up Services. Look around in there for any services that shouldn't be running. If you don't know, it's probably best to leave it be. You could probably just STOP any services that you think might be causing the problem rather than completely DISABLING them. That way, if you goof up, a reboot should put everything back the way it was.
  4. Gus K

    Gus K NTFS abuser

    Seems like it can't be all that important. I have it blocked in Sygate (no outbound access). Works fine.

    But even before I blocked it, I didn't have the problem you speak of.
  5. yoyo

    yoyo _________________

    Killing a process and restricting its internet access are different things.
    Svchost.exe is a generic host process name for services that run from dynamic-link libraries (DLLs). So if you close it you may stop services you need.
    (Information about svchost.exe can be found here)

    The reason for the problem is most likely not svchost.exe, but one of the services run by it. Check eventviewer for error messages and look in Adminsitrative Tools - Services which services are run under the "network services" account. Then sort out those who are run by svchost.exe (BlackViper) . You will be able to narrow down the problem this way.
  6. Enyo

    Enyo Moderator

    Further to what yoyo said note down the PID from task manager (need to go to view and select the PID column) of the instance of svchost that is causing the issue (multiple instances of the process exist, two or three)

    Then drop into the command line and run " tasklist -svc ".

    You can now see the services running under the process causing the issue and stop the appropiate services instead of hunting around.


    You now have the internal service names and stop/start them with net stop <service> or through the services MMC.

    A couple of ways you can troubleshoot it then, i would trial and error with the info from tasklist's output.
  7. bastupungen

    bastupungen Guest

    YEY!!! i have had some progress!!! =D...
    the service DNS CLIENT in services was started when i hadn't shut SVCHOST(network service) off... and when the SVCHOST was shutdown the DNS CLIENT service was not started...
    so i tried to stop that service and now the computer runs fine...

    so the DNS CLIENT is the bully... do i need that service in anyway or can i deactivate it?
    By the way do anyone know what the *beep* caused this?
  8. Enyo

    Enyo Moderator

    You can run without this service but if you are in a domain you should not and if you use IPSEC you cant.

    Give it a shot in manual and monitor for errors.

    As for cause of this problem your cache settings may set incorrectly and be caching info for too long causing your system to have to check alot of entries in the local cache. Thats a shot in the dark. Check the settings of the keys talked about in that article.

    If you have no problems with the service in manual your sitting pretty, if not you could lower the settings so that the cache is virtually empty.

    It could also be a issue with your DNS Server and the responces it sends, you can always change this, you dont have to use the one on your ISPs network.
  9. BlackVinyl

    BlackVinyl Guest

    Hi there. I'm new to this forum but this topic is of slight interest to me. If some body could help, it would be appreciated.
    My OS is Win 2k, but when I try and run 'tasklist -svc' in a command prompt window, I get the error 'tasklist' is not recognized as an internal or external command, operable program or batch file.
    Is this command only for WINNT?
    Any other suggestions to stop this svchost.exe error from happening would helpful.
    Everytime it happens it does weird things to my pc.
    For example, opening control panel and all is reversed. ie icons in the left window pane and blank on the right.
    Or...I can't copy and paste links into an address bar...hell, I can't even disconnect from the net when finished. I need to re-boot.
    Please help...
  10. Enyo

    Enyo Moderator

    tasklist is only for XP. You need to use tlist -s
  11. BlackVinyl

    BlackVinyl Guest

    thank you Enyo, but I think I may have found another reason why I am now getting this error....I have located a prog that seems to be running without me wanting it too.
    It's called mblast.exe... :)
    A whole different kettle of fish.
  12. BlackVinyl

    BlackVinyl Guest

    Perhaps the blast virus wasn't at fault, because I removed it and still have the same problem.
    I tried tlist -s but it still will not recognize the command.
    Is there anything else I can try?

  13. lucas

    lucas Guest


    You will need to go to , they have a link to the virus that will tell you how to get this virus off your system.

    You will have to delete the file as well as del a line in the register file.

    good luck
  14. Madcow69

    Madcow69 Guest

    i'm using win 98 and download a program off of winmx. when i opened it, it had planted this SVChost application on my comp. every time i start the comp. it starts copying file in a file under c:/windows/MyShares. i can't find in msconfig start up options, or the application it self. how am i supposed to get rid of it?
  15. Enyo

    Enyo Moderator

  16. Enyo

    Enyo Moderator


    You need to install the Support Tools. I should have mentioned that sorry!
  17. jileiwin

    jileiwin Guest

    My os is windows xp home edition,when I run 'tasklist -svc' in a command prompt window, I get the error 'tasklist' is not recognized as an internal or external command, operable program or batch file too .What shll I do?thanks
  18. Enyo

    Enyo Moderator

    See your other thread here. Where i have linked you to the tasklist tool.
  19. Android412

    Android412 Guest