Spool32 woes

Discussion in 'Windows Desktop Systems' started by Funkyb, May 12, 2005.

  1. Funkyb

    Funkyb Simple

    Messages:
    82
    Location:
    Melbourne, York
    I have two machines both running win98se. One machine is hooked up to a HP laserjet 2200. The other prints to it through printer sharing. The problem I have is the one without the printer gets a spool32 error. There is no set pattern to it, it may work, it may not and it may also appear even when I dont want to print. The error is as follows

    SPOOL32 caused an invalid page fault in
    module <unknown> at 0000:00000000.
    Registers:
    EAX=ffe97e87 CS=0187 EIP=00000000 EFLGS=00010246
    EBX=bff748b4 SS=018f ESP=01adfea8 EBP=bff749d0
    ECX=00000009 DS=018f ESI=00000005 FS=446f
    EDX=81d97530 ES=018f EDI=bff7c7ac GS=4616
    Bytes at CS:EIP:
    18 00 00 00 65 04 70 00 16 00 c9 09 65 04 70 00
    Stack dump:
    7fe41a56 00000002 00000000 00000005 00510730 00000200 01adff1c 01adff20 bff749d0 bff7c7ac 00510730 bff748b4 01adfefc bff7b498 8435500c 00000000


    Any ideas.
     
  2. LordOfLA

    LordOfLA Godlike!

    Messages:
    7,027
    Location:
    Maidenhead, Berkshire, UK
    I had a similar issue at work with our Brother 8840 multifunction device hooked up via ethernet. Except in my case it'd eat 100% cpu.

    I resolved it by tinkering with the spool settings until it stopped swallowing my cpu whole. Have a tinker and see if you can solve it without having to resolve to reinstalling drivers and re-extracting the spool32 exe from the cab files.
     
  3. IDLE

    IDLE OSNN Senior Addict

    Messages:
    375
    try using the generic driver for HP. its the HO 4 driver. this driver will print to an print device. if this gets the same error you have an issue with the spooler service. kinda hard to modify on 98....