Sound Blaster Live 5.1 Platinum

Discussion in 'Windows Desktop Systems' started by Mathachew, Jun 30, 2005.

  1. Mathachew

    Mathachew Wise Beyond Youth

    Messages:
    53
    Location:
    Texas
    I've got a slight dilema that's been around for a few years, but I figured I'll get off my lazy butt and do something about it:

    I bought a SB Live 5.1 card about 4 or 5 years ago when I built my PIII machine. A few years later, I purchased the Platinum extension from a person who no longer needed it. Along with this came the remote and a burnt CD with software from Creative's website, but not the original software.

    Unfortunately, the software on Creative's site only has an upgrade for the Remote Center and pretty much won't help me out by getting me the full install so that I can use the remote.

    Does anyone here happen to have the original SB Live 5.1 Platinum software? :D
     
  2. Petros

    Petros Thief IV

    Messages:
    3,038
    Location:
    Pacific Northwest
    http://drivers.soft32.com/driver/download-Creative_Audigy_SoundBlaster_Live_Driver_CD-4034.html

    Hopefully this is what you're after. I have no idea why Creative hides its software from the public; I downloaded and installed this myself after much pain--at first the stuff refuses to install, but I figured out how to do it (don't ask me how...I don't remember :D).

    I ended up just getting angry with the poor performance (and unnecessarily low volume output) and using the KX drivers, which are fully functional with the LiveDrive, along with adding total control of pretty much everything you can think of in your card. I can't vouch for whether or not the remote works, however. I haven't been able to find the thing since 2003.
     
    Mathachew likes this.
  3. Mathachew

    Mathachew Wise Beyond Youth

    Messages:
    53
    Location:
    Texas
    iyawetnag8odbadsfgasmetlw34ketj

    In other words: OMGOSH! IT WORKED! THANKS!
    There were several folders, one being Audio. Under that folder was each feature that worked on the Platinum package, one being the remote. I ran the install in that folder and viola! w00t!!

    Unwonted, muchos gracias senior!