Slow startup.

Discussion in 'Windows Desktop Systems' started by Otter21, Feb 4, 2002.

  1. Otter21

    Otter21 Guest

    My startup time has suddenly increased dramatically. The LED light now travels across the screen over 20 times before it brings up the desktop - it is usually about 7.
    I have checked the Event Viewer and sorted a couple of errors, and now no errors are reported on startup.
    I have stopped all uneccesary applications running at startup.
    When I go to Restart or Shutdown I always get the message 'Closing Network Connections'. I run a stand-alone computer so don't really understand this.
    One thing that has changed is that Norton AV is enabled immediately the desktop comes up - before I used to have to wait for it to load.
    Could it be a fight for resources? If so, is there anything I can do about it?
    Any help or advice would be appreciated.
  2. allan

    allan Guest

    Start by going into msconfig and unchecking Workstation.
  3. Otter21

    Otter21 Guest

    Hi allan - thanks for replying.
    'Workstation' was already disabled when the prob began. I have now been through every service checking on dependances, etc and have disabled all those I don't need.
    Things have improved, but not drastically. I have a feeling it could be to do with NAV loading at startup in a different order to before, that is - before other apps. However, I have tried disabling it and it didn't make any difference.
    Before, when I got to the desktop I had to wait for the auto-protect to start - now I don't, so I suppose overall it doesn't make much difference.
    Things seem to be running OK and I'm not getting any errors in the Event Viewer, so I'll leave well enough alone for now!
    Thanks again.
  4. allan

    allan Guest

    Otter - No, NAV is not the issue. You should also download a copy of BootVis and run it. This MS program will evaluate and optimize the programs that run when your system starts. Startup time will improve - sometimes minimally, sometimes drastically.
  5. Otter21

    Otter21 Guest

    Thanks, allan.
    I actually downloaded Bootvis yesterday but haven't installed it yet. I will do so and report back on the results.
  6. Otter21

    Otter21 Guest

    OK, I've unzipped the file - but there's no Help file.
    Could you please give me brief instructions on how to use it?
    Many thanks.
  7. allan

    allan Guest

    It's really pretty intuitive. It needs to be run twice.

    First time click on evaluate or examine or something like that (sorry, I'm in my office and it's not an xp system). This will cause bootvis to examine what's going on at the next boot. Then go ahead and reboot.

    Run bootvis again and this time click on optimize. You will reboot and when Windows comes up there'll be a couple of bootvis screens, one telling you that it is in the process of optimizing. This can take a few minutes - let it do its thing. You will know when it is finished.

    That's it. Now reboot and see if it helped.
  8. allan

    allan Guest

    PS - Otter - feel free to contact me by icq (985598) or aim (adg1111) if you run into any issues.
  9. Otter21

    Otter21 Guest

    Hi again allan.
    I found Waddy's 'Windows XP Startup Tweak Guide' which told me how to run Bootvis.
    I ran it and checked out a few other things - Quick Power On Self Test was already enabled, and I disabled Boot Up Floppy Seek.
    I already use Mike Lin's excellent Startup Cpl (and the equally useful Startup Monitor) but I double-checked to see if anything could be unchecked.
    I then ran Speed Disk, which I do regularly.
    The end result wasn't much of an improvement - about 10 secs.
    It takes approx 90 secs for a reboot (from the black screen to the desktop). Considering I used to have to wait for 45+ secs for the AutoProtect to load after getting to the desktop, I'm happy with it.
    Thanks again for all your help.
  10. allan

    allan Guest

    Just one last thing to check Otter - I'd like to make sure your prefetcher setting is correct. Could you open regedit and navigate to:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters\EnablePrefetcher

    and make sure the value is set for 3 please? This will ensure that prefetcher is optimized for both boot process and application launch.
  11. Otter21

    Otter21 Guest

    Hi allan.
    I did as you suggested and the data for EnablePrefetcher reads as follows:-


    Is this as it should be? Sorry, I'm not really "au fait" with the registry just yet - but I'll get there.

  12. allan

    allan Guest

    Yes, that is the correct setting.

    That Closing Network Connection message is bothering me. I'm going to check with someone and get back to you in a while.
  13. open_source

    open_source Guest

    Do you have a NIC in this computer? If so you might try disabling it in the Device manager. If you have a firewire card also disable the 1394 Adapter under network adapters.

    Also, what type of internet connection do you use? dial-up, dsl, cable?
  14. relder

    relder Guest

    Open_source probably hit the nail right on the head.

    The are network related processes that need to shut down even if you're on a stand alone PC. That message is normal, but if the time period doesn't improve you could also try a registry hack to speed things up.

    The default time out for closing networking processes is 20 seconds. This is cumulative. If there are multiple processes it could be 20 seconds for one + another 20 seconds for another.

    To change this, the registry key is under HKEY_CURRENT_USER\Control Panel\Desktop

    The name is WaitToKillAppTimeout. You can lower the value there. This entry is expressed in milliseconds, so add three zeros to the end of your number. EX: 8 seconds would be 8000.
  15. allan

    allan Guest

    Otter - Rob Elder & Open_Source are two very knowledgeable individuals. You can't go wrong following their advice.

    BTW, your boot time isn't really that far over the line. Good luck Margaret.
  16. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    new york
    Open_ Source, Relder, and Allan ARE ABSOLUTELY the most knowledgeable people ...comes to computers...listen to all of these people (hello Open_Source)
  17. Otter21

    Otter21 Guest

    Hi open_source and relder. Thanks for your input.
    I'm afraid I don't know what NIC is, but there's nothing in Device Manager resembling that.
    I don't have a firewire card.
    I use a dial-up connection (AOL - for my sins!).
    I re-installed AOL last week because I suspected the 'Closing Network Connections' had something to do with it, and there was an icon in Network Connections that referred to LAN. That is no longer there after the re-install, but I know AOL changes many settings.
    In Internet Options/Connections/LAN there is a tick against 'Automatically detect settings' - is this relevant?
    I appreciate your help, although my problem seems rather trivial and is nothing compared with the disaster which resulted in re-installing XP!
  18. relder

    relder Guest

    NIC stands for Network Interface Card and is slang for network card. It shows up as 'local area connection' under network properties. If there was one there before you reinstalled AOL and its gone now that might part of the problem. Many services are tied to the NIC.

    If you have a NIC, try going to device manager, view and select show hidden devices. In the network adaptor section, uninstall everything in the list. Do the same for any devices in the other device section.

    Click on Action, then scan for hardware changes

    Reboot and see if the time doesn't improve
  19. Otter21

    Otter21 Guest

    OK - I'm a bit confused. I can't find Internet Properties, only Internet Options. Under Network Connections only AOL is shown. I did what you suggested in Device Manager anyway, and there were 7 entries under Network Adaptor - only 1 could be uninstalled. AOL then told me it was "Installing Network Adaptor Files" when I logged on.
    I did the scan for hardware changes and rebooted. There was no change in the time.
    I don't know if this relevant, but during startup the LED light whizzes across several times and then slows and stops. This happens several times (as though it is struggling to load something) and then speeds up again before closing.
    There are no errors in the Event Viewer Devices or Applications sections.