Sharing ADSL via router/switch problem

Discussion in 'Windows Desktop Systems' started by ray_gillespie, Mar 17, 2005.

  1. ray_gillespie

    ray_gillespie Moderator Staff Member Political User

    Messages:
    1,692
    Location:
    Birmingham, UK
    Hi,
    I've got a problem similar to the one outlined here. However, the issue with mine is that I cannot log into my router to disable DCHP.
    I have just had my broadband activated, and the USB ADSL modem that came free (I think it's a speedtouch 330) has assigned me an IP address of 192.168.0.1.
    Problem is, that used to be the IP address of my Belkin cable router which I intend to now use as a switch.
    So how can I find the IP address of my router, in order to disable DCHP? Also, I'm a bit confused about this, how has my USB ADSL modem assigned me 192.168.0.1 if my router was doing that?

    Help please! I'm going mad!
    Rep points available :):)
     
  2. brummie

    brummie OSNN Addict

    Messages:
    57
    Location:
    Stourbridge, West Mids. UK
    Modem cant assign that IP address only the WAN address from your ISP.

    START - RUN - cmd.exe

    In the command box type: 'ipconfig /all' (without the quotes)
    Press ENTER.

    All your network info should be in there.
     
    ray_gillespie likes this.
  3. Electronic Punk

    Electronic Punk Administrator Staff Member Political User Folding Team

    Messages:
    18,590
    Location:
    Copenhagen, Denmark
    Could avoid the whole situation and give you systems static ip addresses?
    Another option would be to reset the router which would give the router an out-of-the-box IP address (usually 192.168.0.1 or 192.168.1.1)
     
    ray_gillespie likes this.
  4. ray_gillespie

    ray_gillespie Moderator Staff Member Political User

    Messages:
    1,692
    Location:
    Birmingham, UK
    Could you give me some more info on this? Do I just assign an IP to all the computers on the network?
     
  5. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    The speedtouch modems often hav built in routers of some kind which do give out private IPs. The modem/router usually sits on 192.168.0.254 if I remember it right. That's why it can give out 192.168.0.1.

    The solution is to set you computer on static IP for a while. Set the IP to 192.168.0.2 or something, netmask to 255.255.255.0 and gateway to 192.168.0.254 (if that is indeed the ip of the modem, ipconfig will tell you).
    Then configure the old router and turn off DHCP and so on. Now you can acctually leave it like this if you want to. The router can sit on 192.168.0.1, it doesn't really matter.
     
    ray_gillespie likes this.
  6. ray_gillespie

    ray_gillespie Moderator Staff Member Political User

    Messages:
    1,692
    Location:
    Birmingham, UK
    Ok, thanks so far guys. However, I can't find the IP address of my old router. I ran ipconfig /all and I've attached a screengrab of what I got.
    I've managed to get ICS going ok with the dial-up, but now that I'm on ADSL, my bro's PC won't use the "speedway 330" connection to access the net. Any clues?
     

    Attached Files:

    • cmd.jpg
      cmd.jpg
      File size:
      111.8 KB
      Views:
      164
  7. brummie

    brummie OSNN Addict

    Messages:
    57
    Location:
    Stourbridge, West Mids. UK
    you've assigned yourself the ip address of 192.168.0.1 which you say is the ip of the router. Enable DHCP.
    Cant the cable from the other PC connect direct to your computer? You will need a crossover cable to do this.
     
  8. ray_gillespie

    ray_gillespie Moderator Staff Member Political User

    Messages:
    1,692
    Location:
    Birmingham, UK
    No, sadly I need to use the router as a switch cos my dad's pc will soon be joining the others.
    What exactly does DCHP do, and what should do it?
     
  9. brummie

    brummie OSNN Addict

    Messages:
    57
    Location:
    Stourbridge, West Mids. UK
    Enabling DHCP will allow the router to assign the PC an IP address so you will not get any conflict with any other user or the Router

    Change it in:

    control panel - Network Connections
     
  10. ray_gillespie

    ray_gillespie Moderator Staff Member Political User

    Messages:
    1,692
    Location:
    Birmingham, UK
    From that screengrab in the earlier post, what is the IP of my router?
     
  11. brummie

    brummie OSNN Addict

    Messages:
    57
    Location:
    Stourbridge, West Mids. UK
    i have no idea. You need to enable the DHCP first.

    It might be worth you getting a ethernet modem rather than a USB one. Then the router can fuction as it should do. No need for ICS and no need for you comp to be on while the others have access to the net.
    Something like:
    http://www.dsl-warehouse.co.uk/product.asp?pr=DSL-300T
     
  12. ray_gillespie

    ray_gillespie Moderator Staff Member Political User

    Messages:
    1,692
    Location:
    Birmingham, UK
    Right, it's working!! I didn't actually change anything, but I think Zonealarm was kicking up a fuss, so I reconfigured it for the network and it worked fine! Thanks to everyone for the help anyway, reps are on their way! :)