Samba shares write permissions

Discussion in 'Linux & BSD' started by AcftMecH, Jan 1, 2006.

  1. AcftMecH

    AcftMecH OSNN Addict

    Messages:
    99
    I have created a network between 2 PCLOS machines using using samba. In the config for the shares, I have them as public, read and write permissions. I can see each machine fine, but do not have write permissions. Im sure it is a simple permissions thing but dont know enough about setting up permissins. Any ideas? Thanks!

    Both machines are setup the same way.. examples below:


    Laptop FSTAB to mount my desktop share:

    //desk/Desk_D /Mounted_Shares/Desktop_D smbfs username=% 0 0


    My Laptop smb.conf reads as follows:

    security = share
    [Lap_F]
    case sensitive = no
    msdfs proxy = no
    path = /mnt/Lap_F
    guest ok = yes
    read only = no
    inherit permissions = yes
    comment = Lap_F
     
  2. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    add writeable = yes to your options.
     
  3. AcftMecH

    AcftMecH OSNN Addict

    Messages:
    99
    thanks for the reply. unfortunately, that didnt work. Changed it and rebooted both machines. could there be a certain chmod command option I need to try? thanks!

    My Laptop smb.conf now reads as follows:

    security = share
    [Lap_F]
    case sensitive = no
    msdfs proxy = no
    path = /mnt/Lap_F
    guest ok = yes
    writeable = yes
    read only = no
    inherit permissions = yes
    comment = Lap_F
     
  4. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    I don't really have any experience using security = share? Do you have write permissions on the mount point? I am trying to figure out what you are doing. So you are mounting a network share locally, then sharing it with samba and trying to write to it? What are all the OS involved. I really think you need to use user level permissions.
     
  5. AcftMecH

    AcftMecH OSNN Addict

    Messages:
    99
    actually I am doing it the only way I know how. That is creating a workgroup, shared directory and creating a mount point for it. I am using PCLinuxOS on both machines with Fat32 directory drives on both machines that will be shared. So if there is a better, more secure way of doing it, please let me know............ and if you know of any step by step websites to do it.

    Thanks again!
     
  6. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    OK, well it can't be a filesystems permission issue since you are using FAT32, FAT32 does not support permissions, everything is set read/write/execute. Try adding rw to your fstab options, e.g.:

    //desk/Desk_D /Mounted_Shares/Desktop_D smbfs username=%,rw 0 0

    Then run

    umount /Mounted_Shares/Desktop_D
    mount /Mounted_Shares/Desktop_D

    Also, this is linux, you do not have to restart to make changes, if you change your samba options, just restart samba, no need to reboot.