runtime error

Discussion in 'Windows Desktop Systems' started by jdn, Mar 2, 2003.

  1. jdn

    jdn I'm trying

    Messages:
    110
    Location:
    Victoria, B.C. CANADA
    I (actually my son) is now getting a c++ runtime error when ever he tries to play any games; e.g. jedi knight, counterstrike, never winter nights, etc.
    I have searched many boards and the problem seems common but no solutions.
    I have the latest bios from gigabyte and video drivers from nvidia.
    Reinstalled windows xp pro sp1
    Have run 2 different virus scanners as well as spybot
    Any ideas???
     
  2. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    Did you reload xp or just go over the top? Only other thing I can think of is to try the latest sound driver. Maybe if you have the latest nvidis driver try going backwards with the driver. I was running v29.42 recently with no problems.
     
  3. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    Also seems that Microsoft Visual C++ Runtime Library has files that are shared. Have any program been uninstalled? Deleted?
     
  4. jdn

    jdn I'm trying

    Messages:
    110
    Location:
    Victoria, B.C. CANADA
    New install but no format
    Can you reinstall the library
     
  5. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    Do a search for this 'MSVCRT40.DLL' on your C drive. It sohould come up straight away if it is there. If not download MSVCRT40.DLL & put it in C:\windows system32. Do a search on the net for it. You probably still have it anyway.
     
  6. jdn

    jdn I'm trying

    Messages:
    110
    Location:
    Victoria, B.C. CANADA
    the file is there and also in the sub dir \cache

    I appreciate the help. This is driving me nuts.
    Searching the net, this error happens in money and ie explorer
    The file RSABase.dll is mentioned alot.
    But I have searched all of our computors for it and it is not installed . Must a 9x file
     
  7. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Messages:
    5,920
    Location:
    Melbourne Australia
    It sounds like something has been deleted somewhere. Maybe not windows as you repaired the installation. From what I've seen around it could be any one of a number of programs causing it. (missing files that is) Have a look in the recycle bin. You never know. If you see any .dll's make note of what it is & right click/restore. Reboot. If it is still no good remove the file again.
     
  8. jdn

    jdn I'm trying

    Messages:
    110
    Location:
    Victoria, B.C. CANADA
    Thanks for the help
    I'll let you know
     
  9. Trdsw20

    Trdsw20 Guest

    Did anybody figure what was happening.
    My friend recently just got the same problem on his computer as well. After 2 fresh reinstalls It still happens and I dont have a clue. It seems to only happen if Im playing videogames and while playing Cstrike it only happens when I use direct 3d. Not open GL but even open GL freezes up.
     
  10. jdn

    jdn I'm trying

    Messages:
    110
    Location:
    Victoria, B.C. CANADA
    What games are you playing?
    I never didi solve the problem.
    Got pissed off and ended up building the box below!
    JUst about done but looking for a goood 9700 v/c
    and a decent dvd-rw annddd ??
    Back on topic
    IN searching the net for this problem, you find it all the time, but the threads peter out, no solutions.
     
  11. bandworthy

    bandworthy Guest

    I remember reading this exact problem which also had its fix in a magazine recently but i have no idea which issue..... but have you installed the lastest version of directx firstly? i think xp comes with 8 but you need 8.1 for most modern games and 9 is even out now.


    This is a long shot but you might want to install the latest 4in1 drivers since you have an AMD these solved some annoying problems for me and in some forums updating the agp driver helps some ppl with C++ Runtime errors so dl this

    http://downloads.viaarena.com/drivers/4in1/VIAHyperion4in1446vp6.exe

    and maybe it will fix it.