Remote Desktop?

Discussion in 'Windows Desktop Systems' started by Krule, Feb 20, 2002.

  1. Krule

    Krule Guest

    I installed remote desktop recently, and enabled it.

    I run the IIS webserver on port 2100 because my isp blocks port

    When I went to my school and typed in..


    It popped up the nice html screen, I typed in the servername, and it said Page cannot be displayed, what's up with this?

    I went home and fiddled with stuff, tried everything, but I can't get it to work, anyone know what's up?
  2. clutch

    clutch Guest

    The ActiveX Control that you should be able to download is setup to run on port 3389, so you will need that opened to the PC in question before you can get the next page to come up in some cases. If 3389 isn't forwarded or opened to your PC, this could be the problem.
  3. Krule

    Krule Guest

    it should be oppened..

    I'm not running any firewall...

    It seems that ANY asp page I try to goto
    (http://localhost/IISHelp or ANYTHING)

    gives me an error 500
  4. clutch

    clutch Guest

    So you are saying that NO ASP pages are working at all, correct? Have you tried HTML pages? How about renaming a HTML page to ASP and seeing if that page works?
  5. Krule

    Krule Guest

    tried that, the .asp pages when renamed to .html work (well they do nothing that asp should, but they display a bit of text)

    Renaming a .html to a .asp crashses ie :p

    So what is wrong here?
  6. clutch

    clutch Guest

    Check the event logs on the server and see if there is anything related to "Active Server Pages" listed. It should just have informational references as to the service starting and stopping. Of course, I am assuming that you at least have "scripts only" enabled for the site in question in your IIS MMC panel. You do have that set, right? Oh, and what are the NTFS permissions to the files that you are trying to access?
  7. Krule

    Krule Guest

    Here is the following error that I obtain from event viewer

    The perms are set to nothing basically (no boxes are checked)

    The server failed to load application '/LM/W3SVC/1/Root/tsweb'. The error was 'Class not registered
    For additional information specific to this message please visit the Microsoft Online Support site located at:

    For more information, see Help and Support Center at
  8. clutch

    clutch Guest

    You might want to try and reinstall IIS to see if that clears up. I have only had 2 IIS (out of quite a few ;)) installs that needed to be reinstalled due to odd issues like this.
  9. Krule

    Krule Guest

    I reinstalled it SEVERAL times, (uninstall, reinstall, uninstall, reinstall)

    Nothing works, help! :(
  10. mattcottrell

    mattcottrell Guest

    Have you tried accessing it from another machine that isn't at school and isn't behind a firewall (eg a friend's). The chances are that your school has not opened port 3389 on their firewall.

  11. clutch

    clutch Guest

    He's having problems loading any ASP page at all. That's a server issue, so his TSWEB client loading problem is related to the fact his server is "broken" rather than a possible port being blocked.