Realtek sound driver sporadically redetecting

Discussion in 'Windows Applications' started by Dublex, Aug 25, 2009.

  1. Dublex

    Dublex Quazatron R6 droid

    Messages:
    624
    Location:
    Hertfordshire, UK
    Has anyone else having a problem with the Realtek Drivers sporodically redecting the black jack port (rear quad speakers?) - its plugged in fully etc, its just annoying to have the what have you got plugged into the black jack dialogue box continuiously come up.

    I'll probably see if a vista or XP driver fixes the issue, but thought I would float it here first. If I find a solution I'll update of course ;)
     
  2. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    you using the latest driver from their site?
     
  3. Dublex

    Dublex Quazatron R6 droid

    Messages:
    624
    Location:
    Hertfordshire, UK
    Yup, at least it should be the latest if windows update got it.

    I'll check tonight just in case - not at my home rig currently.
     
  4. fitz

    fitz Just Floating Along Staff Member Political User Folding Team

    Messages:
    4,076
    Location:
    Chicagoland
    not sure of others opinions on this.. but personally, I never use windows update to update my hardware drivers
     
  5. roirraW "edor" ehT

    roirraW "edor" ehT Builder/Installer

    Messages:
    529
    I only do as a last resort.

    It could be a hardware issue. Either the jack itself or even the wiring/speakers?
     
  6. American Zombie

    American Zombie Moderator Staff Member Political User

    Messages:
    2,931
    Location:
    Seattle
  7. Dublex

    Dublex Quazatron R6 droid

    Messages:
    624
    Location:
    Hertfordshire, UK
    Think I'd better clarify the situaiton a bit as I was doing some more investigating yesterday and was mistaken about the sound chipset.

    I've been doing some more digging, and I found out after looking around the config its a Soundmax HD audio on board sound card (part of the Ausus P5K Deluxe board chipset) More specificlally, the board has a ADIĀ® AD1988B 8-channel High Definition Audio CODEC which uses the soundmax Blackhawk drivers (thats the drivers that came with the original board setup anyway)


    It also seems that Windows 7 doesn't really have fully functioning drivers for ASUS - Soundmax yet at least for greater than a quad speaker setup - well, I guess it does work as all the sound kicks in on all 4 speakers when launching a DirectX game but I only get 2 speaker sound in windows, and some apps decide to launch using the sound on the rear two speakers only.

    One solution appears to be to ditch the blackhawk drivers (soundmax drivers) and use the windows HD audio codec - and the SRS surround program I have does mix the sound to 4 speakers - but really it would be good to find a driver version that works without having to resource to remixers.

    Anyone have any ideas of what drivers to use? The Latest Vista 32 blackhawk drivers seem to be a bit better, but still no dice on 4 speaker sound in Win 7 itself outside of gaming and it still sometimes flips speaker audio.