Really Wierd Internet Problems

Discussion in 'Windows Desktop Systems' started by JeremyC, Dec 10, 2001.

  1. JeremyC

    JeremyC Guest

    Ive got some really wierd internet problems....

    Im running WinXP and Im connected to the internet through a cable modem. Now when I boot my computer everrything runs fine, I get a connection to the net, I can open ICQ and MSN, and webpages work.

    Now after about 5 minutes of working fine, I try to view a webpage and it gives me the 404 ERROR like the page isnt there or something. I even tried pages like Yahoo and CNN to make sure it wasnt something on my end.

    Well I went to the command prompt and did:

    ipconfig/release

    This released 0.0.0.0

    Now I have an IP address so this must have just changed because somehow I lost my internet connect.

    I go back to the command prompt and type:

    ipconfig/renew

    And I get my IP back and everything works fine.

    The funny thing is that when my internet connection seems to die I can still do my messenging. I can send/recieve files and messenges, yet I cant view any webpages. Wierd isnt it.

    Hope someone can help me out here. Thanks....

    -Jeremy
     
  2. Lonman

    Lonman Bleh!

    Messages:
    2,642
    I'm going to take a shot in the dark and suggest it may be your firewall utility. You might try uninstalling and reinstalling it to see if that helps.
     
  3. sstrick

    sstrick Guest

    I'm guessing you have Internet Connection Sharing enabled. I am having the same problem. I just choose the repair option on the card connected to the hub(not the card connected to the cable modem). I don't know why this is happening, but it is not a firewall issue. The exact thing is happening to me. I would be interested to know whether you are using ICS. I even tried using a proxy server rather than ICS and it still locks up after awhile. If I unshare the internet connection everything works fine. Any others have this problem?
     
  4. JeremyC

    JeremyC Guest

    I already tried that. I even uninstalled it completely so it wouldnt run when Windows booted and still got the same problems...

    -Jeremy
     
  5. JeremyC

    JeremyC Guest

    I am using File and Printer Sharing. We've got 3 computers all running on the same IP through a router. Two of us are on WinXP and the other is on Win98. The comp on Win98 doesnt lose its connection ever, but both of us on WinXP are.

    -Jeremy
     
  6. sstrick

    sstrick Guest

    seems like we are having the same issue. This problem is new since the AT&T "transition". I don't know what could be causing it. I did find that shuting down MSN Messenger on the Win98 machine helped a lot but the http aervice still locks up from time to time. Each time I hit repair on the connection going to my hub, rather than the one going to my cable modem and everything works fine until it happens again. I have tried changing every setting I know of on all my network to no avail. If I figure it out I'll let you know.
     
  7. sunofjay

    sunofjay Guest

  8. stef_nz

    stef_nz Guest

    that last post rings a bit true for me. periodically my firewall blocks outgoing dns from my web browsers for no good reason giving me those errors.

    i wonder if my firewall software hiccups every now and then - i hope not. it happens so rarely that i just reset the machine.

    i can't recall it happening back when i was on dialup so who knows if its my dsl or not?!?!

    if someone manages to disseminate all these posts into a solution i'd love to hear it.

    :confused:
     
  9. sstrick

    sstrick Guest

    Thanks sonofjay,

    Setting the recovery failure option to restart in the computer management-services and applications-dns client service seemed to do the trick. I didn't have a whole lot of time to test it, but I tried hitting a bunch of my favorites (which would usually lock me up) and everything was working fine. If I have any more problems, I'll try shutting the service down and see what happens. The others in the post you refered me to shut down the service and that seemed to fix their problem. i don't know what other programs depend on this service so I though I would just use the restart on failure option and see what happens. Let me know if this worked for you.
     
  10. sstrick

    sstrick Guest

    after reading those posts further I'll forward what was said there and the solution:

    solution 1vfrom alpha996:

    "Fix for DNS problems in XP
    Look at the list of DNS servers (ipconfig /all), two start with 216 and 204 and two will start with 12. Attbi uses the 12.x.x.x servers for internal machines. They only resolve mail and news and respond with an authoritative "host not found" if they try to resolve any other name. Their servers should forward queries to a DNS server that can resolve the name, in this case the ones that start with 216.x.x.x or 204.x.x.x or respond with an un-authoritative "host not found" so XP would try another DNS server. The reason for sporadic results is that XP will sometimes try the 12.x.x.x servers first and XP gets returned the wrong answer. ATTbi needs to fix this (and will I believe). In the mean time the best fix would be to ONLY change the "Obtain DNS servers automatically" to "Use the following DNS server addresses" and enter only the other DNS servers, 216.148.227.68 and 204.127.202.4. Then be sure to use mail/news with the full domain names, as mail.attbi.com and netnews.attbi.com. This can be changed back to "Obtain automatically" when ATT fixes the resolution on there servers. This should also up your throughput. I believe this will fix DNS problems with Win98, WinMe, and 2000 also. Hope this helps."


    Solution 2 from bigjoesmith:

    "Regarding the "page not found" error (for obviously existing pages) that people are reporting. Here is what is happening and a suggestion on how to fix the problem.

    Before a web page like www.yahoo.com can be loaded, the domain name must be resolved to an IP address (e.g. 64.58.76.228). This resolution is performed by a domain name server (a DNS server). Each resolution by a DNS server returns the proper IP for the domain name and a TTL (time to live) value for the resolution. The TTL specifies how long the result may be cached. Caching allows subsequent resolution to take place directly out of the local machine's cache rather than going over the network to the DNS server. Caching is a good thing. Windows 2000 and Windows XP have client DNS resolvers that cache.

    As it happens, some of attbi.com's DNS servers are, at times, returning bogus resolutions. In particular they are failing to resolve valid domain names. Windows 2000 and Windows XP can also cache negative responses. So when Windows XP asks an attbi.com name server for www.ibm.com and gets a response that www.ibm.com does not exist, Windows will cache this negative response. Likewise, when the client resolver gets a negative response from any DNS server on it's list of DNS servers, it stops any other pending queries for the same name on any other DNS server. This is by design. Subsequent requests for www.ibm.com will immediately return "does not exist" until the cached negative response times out and is removed from the cache. With a non-caching DNS resolver (e.g. such as Windows 95 has), subsequent requests will once again query a DNS server.

    So with DNS servers that return false negative responses and a client resolver that caches negative responses you can get the kind of resolution problems that people are reporting (and which I have witnessed myself).

    Some people have suggested solving the problem by using different DNS servers. This will indeed work if the chosen DNS servers function correctly and do not return bogus responses. However, in a DHCP-configured environment like attbi.com's, it's best, in the long run, to accept and use the DHCP-supplied DNS servers. This allows attbi.com to manage things automatically over time. attbi.com DNS servers should, as attbi.com gets it act together, be faster to respond than other servers since they will be closer (network hop wise) to your machine. Finally, other ISPs won't enjoy you using their servers.

    Some people have suggested turning off the DNS resolver service (the client side DNS resolver) on Windows 2000 and Windows XP. This will indeed work for this failure case. However, turning off the Windows DNS resolver is not an optimal solution. I don't recommend it. The resolver is a very handy piece of code that does a lot work and has a lot of smarts to accomplish DNS resolution effectively. In particular, caching is a good thing. However, negative response caching, particularly in the face of false negatives, may not be ideal.

    A better solution would be to limit or turn off negative response caching. This is accomplished by setting the NegativeCacheTime registry entry (HKLM\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters). The NegativeCacheTime registry entry specifies for how many seconds negative responses are cached. The default value is 300 seconds. Setting the value to 0 will specify that negative responses should not be cached at all. (NegativeSOACacheTime should also be set to 0 if you want to turn off all negative response caching.)

    For more information, see »www.microsoft.com/technet/treeview/def..[?]

    (Some have pointed out that this URL is broken. For more information about the DNS client resolver in Windows 2000/XP, go to »www.microsoft.com/technet[?] and search for "DNS Caching, Network Prioritization, and Security".)
    [text was edited by author 2001-12-06 03:26:11]"
     
  11. sunofjay

    sunofjay Guest

    sstrick,

    I tried the registry changes first, setting NegativeCacheTime and NegativeSOACacheTime to zero. This did not work for me, although I did receive the 404 error less often. I have disabled the dns client. Seems to work fine I have not had any errors since.
     
  12. sstrick

    sstrick Guest

    did you try manually setting the dns servers? This worked for a lot of people.
     
  13. JeremyC

    JeremyC Guest

    Hey thanks for all the help!

    I went ahead and put in the DNS servers I got from ipconfig/all and it worked perfectly. Thanks again.

    -Jeremy