"read only" problem

Discussion in 'Windows Desktop Systems' started by KevD, Feb 1, 2002.

  1. KevD

    KevD Guest

    Having recently reformatted my hard drive, reinstalled XP & copied across my backed-up files, settings, drivers etc. I have found that all my folders are "read only". If I uncheck the boxes & apply the changes, it appears to make the changes but when I go back to properties, I find that it is back to "read only". Any suggestions?


  2. Qumahlin

    Qumahlin Moderator

    I've noticed this also, all my folders say they are read-only, but I can still read and write to them as normal, is this the case with you, or are your folders actually read-only and will not let you write at all?
  3. jairo

    jairo Guest

    the only thing that worked for me is the rd command (remove directory) from the cmd prompt.it is the only way i found to delete
    directories.(all of my directories are set to read-only without being
    able to change the attributes)
    is it a registry problem?
  4. Mister Zee

    Mister Zee Guest

    attrib -r *.* /s

  5. jairo

    jairo Guest

    that doesn't remove the read-only attrib i have on all my folders.
    the files inside the folders are deletable but not the folder itself.
  6. Mister Zee

    Mister Zee Guest

    Then do this too:

    attrib -r *. /s

    (drop the last *, folders can be found this way)
  7. Lukas

    Lukas Real Name No Gimmicks

    I think the switch /d makes attrib clear/set an attribute on directories as well.

    go in command (run box-> CMD) and type attrib /? for help.

    Im not sure bout the switch coz apparently NT4 doesn't have it...
  8. firehawk

    firehawk OSNN Addict

    This is a GUI bug where it shows the box as being "checked" when it really isn't. Nothing to worry about.
  9. Lukas

    Lukas Real Name No Gimmicks

    I don't think so...

    the box can be checked and kind of grey-ish. That only means that some of the underlying folders/files are read only.

    You can double check with attrib
  10. firehawk

    firehawk OSNN Addict

    True......but on folders that would not normally be set to read only $MS explaination for this is a bug showing that it is set to read only when it isn't. Just try to keep that box cleared........bet you can't do it!