read only files after restore (server 2003)

Discussion in 'Windows Server Systems' started by Mainframeguy, Jul 3, 2007.

  1. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    long time no post - still seeking employment here - but been offering my services to the local voluntary centre free and found their small business server only had a 20GB data drive with only 3% remaining!

    SOOoooo I gifted them a spare 80 GB drive I had, installed it, used the server backup to back up files to an external HD, then used disc management to reallocate the D drive as drive I and allocated the new drive as D and restored to it.... all appeared in order but then I foudn the files were all marked read only.

    SOOooo I thought I would just reallocate the drive letters back to their orginal so the data became D again, but still the files are read only!

    Obviously I am missing a step, and when I get it right I can give them the drive with more space, but at the moment I have egg on my face having somehat stuffed their server!

    Can you guys help me out with the missing step? Or and alternative approach to put things to rights? I sure hope so as I feel bad about this since they trusted me... I know I have lost no data, but they need to be able to use that server and update again!

    I am heading back in there in about twelve hours or so, early tomorrow morning, so any quick answers very much appreciated!

    PS after a little preliminary googling it may be worth saying I do not think I was using the shadow volume backup, just the regular server admin backup.... I can sort of see how it might be that the restored data was marked read only (I did try making them shareable and enabling write access, but this did not help) but cannot see why on renaming drives back the original was also marked read only! All help appreciated even if it is just pointers where to learn more.... Oh and if there is any other approach for me to take to get this fixed and give them a useable server again with their data then please do post!
     
    Last edited: Jul 3, 2007
  2. LordOfLA

    LordOfLA Godlike!

    Messages:
    7,027
    Location:
    Maidenhead, Berkshire, UK
    Thats pretty easy :)

    Fire up explorer, go to the root directory, select all files and folders, right click and uncheck read-only. Tell it to apply to all subfolders and files and grab a coffee :)
     
  3. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    HMMMmmm I tried that, did not seem to make any diff. Have to have another look
     
  4. Steevo

    Steevo Spammer representing. Political User Folding Team

    Messages:
    2,566
    Ownership privilages more tha likely the problem. Sorry Ihave had a few shots.


    Make sure that you are signed in as the named Administrator, and then try it, if that doesn't work then choose to boot to safe mode and try it. If not then you might have to take ownership of all the files then use computer managemnet to allocate useage rights. Or you might try that first.
     
  5. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    Well I am back onsite now and have retried the read only and indeed that does not work, you can uncheck the box and apply it but then when you come back it is still read only...

    But I have checked under computer management and it appears shadow copy is enabled for the old drive, but not for the new one, could this have a bearing on the problem? And if so what corrective action, do I disable it for the old drive and enable for the new?
     
  6. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    well I found this but even after I follow the corrective action there I still get no joy... this is proving to be quite a pain, any more ideas? Oh and I have removed shadow copy from old and enabled for new drive also....

    [EDIT] Actually this seems to have worked, but I had to remap the drive from D:\DATA to D:\D$\DATA which I do not understand, nor that the explorer properties still shows the folder as read only even when it seems not to be![/EDIT]
     
    Last edited: Jul 4, 2007
  7. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    One last thing - if anyone can advise, does it have to require users to remap the network drive after this change? Seems I had to but wondering if there is any way around this so that the change can appear seamless for the users?
     
  8. Mainframeguy

    Mainframeguy Debiant by way of Ubuntu Folding Team

    Messages:
    3,763
    Location:
    London, UK
    ARGH... I thought this was fixed but now I go back to the files and they are read only again! Any idea what is going on anyone?

    [EDIT] found cause of discrepancy, was because I had admin permissions and others did not, can I resolve this without giving others administrators permissions or is that the only quick fix? [/EDIT]

    [EDIT] That does not seem to help, anyone got any other ideas here? I'm running out of options and time and no idea what to try next, also still do not understand why I cannot fall back to the original drive with the low free space [/EDIT]
     
    Last edited: Jul 4, 2007
  9. Steevo

    Steevo Spammer representing. Political User Folding Team

    Messages:
    2,566
    Lemmie log into our server at work, I only have XP home here.
     
  10. Steevo

    Steevo Spammer representing. Political User Folding Team

    Messages:
    2,566
    Run a scandisk and see if you get any errors generated by the security descriptors.


    And what account did you run the copy under?
     
  11. Steevo

    Steevo Spammer representing. Political User Folding Team

    Messages:
    2,566
    And add the account you are using to the Backup Operators group.
     
  12. Steevo

    Steevo Spammer representing. Political User Folding Team

    Messages:
    2,566
    Also check security settings and make sure that you have been assigned the rights to make shares and other things.
     

    Attached Files: