Quake 3 problem...

Discussion in 'PC Gaming' started by Xeroe, Feb 7, 2003.

  1. Xeroe

    Xeroe Guest

    Q_strncpyz: NULL src

    wtf? Any ideas?
     
  2. Xeroe

    Xeroe Guest

    Q3 1.32 win-x86 Oct 7 2002
    ----- FS_Startup -----
    Current search path:
    C:\Program Files\Quake III Arena\baseq3\snd-ash.pk3 (16 files)
    C:\Program Files\Quake III Arena\baseq3\pak8.pk3 (9 files)
    C:\Program Files\Quake III Arena\baseq3\pak7.pk3 (4 files)
    C:\Program Files\Quake III Arena\baseq3\pak6.pk3 (64 files)
    C:\Program Files\Quake III Arena\baseq3\pak5.pk3 (7 files)
    C:\Program Files\Quake III Arena\baseq3\pak4.pk3 (272 files)
    C:\Program Files\Quake III Arena\baseq3\pak3.pk3 (4 files)
    C:\Program Files\Quake III Arena\baseq3\pak2.pk3 (148 files)
    C:\Program Files\Quake III Arena\baseq3\pak1.pk3 (26 files)
    C:\Program Files\Quake III Arena\baseq3\md3-homer3d.pk3 (37 files)
    C:\Program Files\Quake III Arena\baseq3\md3-ash.pk3 (54 files)
    C:\Program Files\Quake III Arena\baseq3\matrix.pk3 (23 files)
    C:\Program Files\Quake III Arena\baseq3\bots_ash.pk3 (10 files)
    C:\Program Files\Quake III Arena\baseq3\Bot-homer3d.pk3 (7 files)
    C:\Program Files\Quake III Arena/baseq3
    E:\Quake3\\baseq3\pak1.pk3 (7 files)
    E:\Quake3\\baseq3\pak0.pk3 (3539 files)
    E:\Quake3\/baseq3

    ----------------------
    4227 files in pk3 files
    execing default.cfg
    execing q3config.cfg
    couldn't exec autoexec.cfg
    Hunk_Clear: reset the hunk ok
    ...detecting CPU, found AMD w/ 3DNow!

    ------- Input Initialization -------
    No window for DirectInput mouse init, delaying
    Joystick is not active.
    ------------------------------------
    ----- Client Initialization -----
    ----- Initializing Renderer ----
    -------------------------------
    ----- Client Initialization Complete -----
    ----- R_Init -----
    Initializing OpenGL subsystem
    ...initializing QGL
    ...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
    ...setting mode 3: 640 480 FS
    ...using desktop display depth of 16
    ...calling CDS: ok
    ...registered window class
    ...created window@0,0 (640x480)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...0 PFDs found
    ...MCD acceleration found
    ...PIXELFORMAT 1 selected
    ...creating GL context: failed
    ...failed hard
    ...restoring display settings
    ...WARNING: could not set the given mode (3)
    ...setting mode 3: 640 480 FS
    ...using colorsbits of 16
    ...calling CDS: ok
    ...created window@0,0 (640x480)
    Initializing OpenGL driver
    ----- CL_Shutdown -----
    RE_Shutdown( 1 )
    Shutting down OpenGL subsystem
    ...wglMakeCurrent( NULL, NULL ): failed
    ...releasing DC: failed
    ...destroying window
    ...resetting display
    ...shutting down QGL
    ...unloading OpenGL DLL
    -----------------------
    Q_strncpyz: NULL src

    This is the whole thing in the starting window, any help greatly appreciated...
     
  3. TechSupport

    TechSupport Guest

    what graphics card have you got? and are you using the latest drivers for it? have you installed dx9?
     
  4. deadzombie

    deadzombie Guest

    Let me guess, this happened right after you installed an update for Q3A? Reinstall your video drivers. Better yet, update them altogether.
     
  5. Xeroe

    Xeroe Guest

    Sorry for the delayed response, i got it working, but now whenever i go to start a game, er actually *play* (load to go shoot stuff) it freezes.... Cmon quake gurus, were r u?
     
  6. jonifen

    jonifen pffff...

    Messages:
    705
    have you changed anything in the config since the last time it worked OK?
    With the latest update of Quake 3 including Punkbuster, its possible something in the config is causing PB to complain - perhaps "/r_subdivisions" being greater than 100.

    Also, is PB enabled? If you're trying to play online without PB being enabled, it'll cause a problem - I remember just loading a game only for it to hang for ages, then kick me back to the main menu.

    Might be worth uninstalling Quake 3 and all its mods, when thats done, delete the folder where it was installed.

    Update your graphics card drivers now (if there are newer ones) :)

    Install Quake 3 and then Point Release 1.32 (including Punkbuster - if you play Q3 online).
    Install the mods one by one


    give that a go... post back if it doesnt work

    one last thing... good luck :happy:
     
  7. Xeroe

    Xeroe Guest

    I uninstalled, reg cleaned, etc. Re-installed, and quake runs. So i start dowloading pr 1.32 and go into quake, watch movie, go into it. Start up single player, click fight, then it brings up load screen, stays there, and i have to Ctrl+Alt+Del... Does the nvidia geforce 3 have a known issue w/quake? Last time it worked ok was before my last format of drives.... havnt changed anythin into weirdness.
     
  8. Xeroe

    Xeroe Guest

    All this is happening before i install the point release.