problem solved

Discussion in 'Desktop Customisation' started by 2z, Jun 5, 2002.

  1. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    many thanks to XP-erience member lisaleese for finding this site
    http://www.dougknox.com
    the offending key is
    HKEY_CLASSES_ROOT\CLSID\{00021400-0000-0000-C000-000000000046}\shellex\ExtShellFolderViews\{5984FFE0-28D4-11CF-AE66-08002B2E1262}


    I’ve managed to get common folder tasks on my desktop (again) there must be another way to sort this out other than restore. All I did was try out the new style
    of start menu for a few days then went back to classic, this is when it happened.
    The time before that I removed all the desktop items (to show off pretty wallpaper)
    By right clicking on the desktop / arrange icons by / show desktop items – untick, reboot then put the icons back. The time before that I removed My Computer icon from the desktop (to stop my kids from having full access) later put it back using
    display properties, that was the first time it happened. So it would seem the problem is in the removal of My Computer from the desktop. Each time I’ve had to use restore to correct the problem. I’ve trawled through the registry looking for a clue
    and tried all the usual avenues, this is really annoying.
    PLEASE HELP!!!!!!!!!!
    See pic
    [​IMG]
     
  2. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    Have you mad sure that you turned off active desktop? usually active desktop being on i sthe culprit for that.
     
  3. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    I have never been any were near active desktop. Have you tried to recreate the problem? Right click on the desktop - arrange icons by / untick show desktop items - reboot & put the icons back. Does this only happen to me has any else had this problem? It would be nice to hear from someone who has tried it & got the same effect even if you dont know the solution at least then I know its not just me. Go on give it a go make my day. PLEASE!!!!!!!!!!. Right click on the desktop - arrange icons by / untick show desktop items - reboot & put the icons back. Simple.

    I've since been told that this bug does not occur if your using themes or any other desktop enhancing program such as styleXP and virtual desktop manager.

    If this happens to you and system restore does'nt work, create a new account for yourself transfer all your short cuts to your new account and delete the old one.
     
  4. Phreak This

    Phreak This Guest

    You guys do remember that XP sorts unused icons into a folder right? Just wondering..;)
     
  5. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    you mean the cleanup desktop every 60 day wizard. definatly not, it was shortly after a fresh install & thats one of the 1st things I disable, thanks for the input :)
     
  6. May I ask a question, how did u get those little groups in the taskbar = pc and mp3?
     
  7. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    right click on your taskbar / toolbars / new toolbar / & browse to the folder or drive - select / ok.
     
  8. I'm to lazy to read the forum, but why is ur tasks on the left showing on the desktop?
     
  9. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    its a windows bug, mine was caused by removing My Computer icon from the desktop.
     
  10. yeah i can delete my computer icon to, i think on Windows ME, u dont have that option?
     
  11. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    it can also be removed using display properties
     
  12. How do u delete it in the display properties?
     
  13. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    open display properties - hit the desktop tab - now the customise desktop button - where it says desktop items untick My Computer - OK
     
  14. X-Istence

    X-Istence * Political User

    Messages:
    6,498
    Location:
    USA
    okay, your problem might be the following problem. In special folders M$ has put a file called desktop.ini. In that file are special keys and settings, including if it is the desktop or not. For some reason when you do delete your My Computer icon it happens to also delete the value that is it the desktop from the desktop.ini file. Meaning that windows will use it as a normal folder, cause all the desktop is, is a folder with stuff in it, just like any oher folder.

    And since desktop is just another folder window open just like double clicking my computer it can also show the easy shortcut stuff. All i think you have to do is get a good file of desktop.ini and replace the one in the folder now.

    Hope it works, worked for someone else i know
     
  15. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    Sounds like good advice, but where will I find the desktop ini file I need to replace ? Ive just done a search for it & there are 101 of theses files on c-drive :confused:
     
  16. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    The Patch Work's

    This time I lost my connection to the internet, (AOL 56k DialUp) not that unusual, rebooted & there it was. Weird !!! The reg hack works a treat, Download here dougknox.com
     
  17. pacou

    pacou Guest

    HELLO

    HAVE YOU FIND THE SOLUTION NOW ?
     
  18. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    :D Yes Thankyou
    also another cause of this bug is Fix-it 4 Registry fixer
     
  19. zyfos

    zyfos Resurrected

    Messages:
    236
    I Think I can fix your prob

    Ok, for one, your desktop.ini file I'm pretty sure is hidden. We can set it up so you can see it and fix the prob in the same place.

    Open up Windows Explorer. Go to the Tools menu and select Folder Options. On the new window, make sure you are on the General tab. Under the Tasks group, change it from "Show common tasks in folders" to "Use Windows classic folders." Hopefully this should fix your problem.

    If you want to see desktop.ini, switch over to the View tab. Select "Show hidden files and folders". (You might also have to uncheck "Hide hidden operating system files (Recommended)".

    Hope that works for ya.
     
  20. 2z

    2z OSNN Gamer

    Messages:
    2,439
    Location:
    England
    :confused: Not to sure how I fix the problem from here I've done everything you suggested, did a search of my boot drive & it came up with 77 matches.
    :confused:
    see pic