Problem Sharing DSL Connection

Discussion in 'Windows Desktop Systems' started by TrIpWiRe31337, Jan 13, 2002.

  1. Here is the setup:
    MAIN COMPUTER: 2 NIC's
    One connected to INTERNET
    Other connect to secondary computer w/ crossover cable

    SECONDARY COMPUTER: 1 NIC

    I can't get the second computer to share. I think there is something set up wrong. I ran the automated setup thingy on bother computers, and on the secondary computer, I can actually see the local Area Network connection, and it actually shows the amount of date being transmitted, from internet -> computer -> computer. But, in the workgroup, only the computer I am on shows up, and I can't use the internet. What did I do wrong?
     
  2. JJB6486

    JJB6486 Retired Mod Political User

    Messages:
    1,207
    Location:
    West Lafayette, IN, USA
    Make sure that you have a visibl file or folder shared. If there are no file shares active, the comptuer does not disply on the network.

    Also, make sure that the workgroup names are the same, and comptuter names are different. Try pinging the IP of the other computer. Let me know if it pings.

    JJB6486
     
  3. After much Tweaking...

    I got the File sharing to work. Now the filez share and I have axess to each computer. But, when I play LAN Gamez, the ping is deathly slow, like 600-700. And still no internet connection. Should the LAN ping be that slow???
     
  4. tastingw

    tastingw Guest

    re

    Make sure that your client computer connect through a lan. The ping is slow did you ping under cmd?? ( maybe there's a difference)

    In your tcp settings of the client also add a default gateway, that would be the ip of your server/router

    let me know!
     
  5. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    High ping? Hmm... It could be a faulty cable. How long is it?

    More likely however, is that the cards are set to different speeds (one 10, one 100) or different duplex (one full, one half). Have you checked that?

    What protocols are installed?
     
  6. Cable isn't longer than 10 feet. They are right acrossed the room from each other. All protcals are installed, here is the list:
    Client for MS
    File and Printer Sharing Stuff
    QoS Packet Scheduler
    NWLINK Netbios
    NWLINK IPX/SPX/NetBios Compatible
    internet TCP/IP
     
  7. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    Maybe one of your NICs is broken? It may work half bad like this if it is. Have you tried changing them? (Did you check the speed/duplex?)
     
  8. Gizzy

    Gizzy Guest

    I had exactly the same problem under WinXP. Both PC's running WinXP. I had LAN connection, both PC's could see eachother, also transfer data and all, but no Internet connection sharing was possible on the 2nd PC.

    So, what I did. Luckily I was able to upgrade my Alcatel DSL modem to a router. So it functions as a router now, and I already had a hub, and so I connected the DSL Modem/Router on the uplink port of the Hub, and the 2 PC and also another Laptop occasionally to one of the 5 ports on the Ethernet Hub. That works now for me without any problem, and the best thing is that I am always online. Meaning not that DSL is online (thats online anyway), but I don't have to dial in the connection each time the one of the PC's reboots. That is taken care for by the DSL Modem now. So as soon as I am logged on in XP, all PC's connected to the hub have access to the net. :)

    I still need a good firewall though, coz the DSL modem got no Hardware firewall. So Zonealarm Pro is doing its work just fine. :) But its better to have a Hardware firewall, so I am gonna get a Vigor 2200E very soon.


    Related link about upgrading Alcatel Modem ro Pro with Router capability:

    http://www.sateh.com/hacks/alcatel.php
     
  9. tastingw

    tastingw Guest

    re:

    Vigor 2200E is GREAT!!

    I've got it, it's perfect, no more network troubles just plugin and of you go
     
  10. Thanx

    For all you help guyz/gals, but I dont have an acatel modem. I am using the telocity/directv Broadband service, and I am using there modem. If anyone knows who made this, and where I can find hacks for it, I would greatly appreciate it.
     
  11. Lactic.Acid

    Lactic.Acid Guest

    Remove QoS, remove NWLINK Netbios, remove NWLINK IPX/SPX/NetBios. You do not need any of these three, and they will do nothing but add lag. The only thing you MIGHT need is IPX, and that's only if a game you play REQUIRES that protocol. Very few do now, though, so you will most likely be fine without. That should improve performance a little bit. Also, do as was noted before and set your network speeds locally to 100Mb full-duplex if your hub or router supports that. Otherwise set it to 10Mb full-duplex.
    /L.A
     
  12. PHESS

    PHESS Guest

    You should share your internet connection.
    Right-Click on your internet con. then properties and somewhere click at "Allow all users...."
    Do the same with the passwort in your dialing window.
    On the other PC go to network prop. Than gateway server. Write your IP there cause you are the gateway server. Also do obtain IP automatically on the client PC. Now it should work.

    I have also 2 PC's at home and my internet connection is perfect. The only problem is the copying of many small files. It makes the network speed much slower but I think it is normal.

    All who have different-speed networkcards at their network should buy a swich and not a hub. Hub is only for the network with the same speed cards.

    I hope I could help.
     
  13. UniSol

    UniSol I'm all ears

    Messages:
    532
    Location:
    UK
    I had the same problem the other day, Everything working fine then out of the blue it stop sharing, I just messed about with the IPs for a while then turned both on auto detect again and it works (for games only) cant browse anymore. The host must have the XP firewall enabled btw!:D
     
  14. PHESS

    PHESS Guest

    You should use passwords.

    Open "Local security Settings" in Administrative tools.
    Then go to "local policies" then "user right assignment"
    Look at the not that beginns with "Deny logon locally" If you see there the name of some PC's in of your network than right click it and delete these names. All but not the support.