Port 21 in use?

Discussion in 'Windows Desktop Systems' started by dosprompt, Dec 7, 2002.

  1. dosprompt

    dosprompt Guest

    Anyone have any Ideas on Why When I try to use Port 21
    on XP for my FTP server it tells me that its already in use?

    How do I free up this Port

    Thanks

    Baz
     
  2. SPeedY_B

    SPeedY_B I may actually be insane.

    Messages:
    15,800
    Location:
    Midlands, England
    Do you have IIS installed ? (or is that what you're trying to use ?)
     
  3. Burpster

    Burpster Guest

    sounds like you may have a ftp server already running..... have you noticed any strange folders on your hard drive(s)?? have you lost alot hard drive space??
     
  4. dosprompt

    dosprompt Guest

    1) No IIs not running

    2) No only one copy of Bulletproof FTP up.

    3) Just Tried my L/T it has XP and has the same fault

    4) My 98SE sys is fine useing Port 21????

    Now totaly lost .....
     
  5. dav3st

    dav3st OSNN Addict

    Messages:
    74
  6. dosprompt

    dosprompt Guest

    Cheers Cool program

    BUT it does not show Port 21 or it may need Translating
    any Ideas...
    I have included a save of the reading

    Thanks
     
  7. SPeedY_B

    SPeedY_B I may actually be insane.

    Messages:
    15,800
    Location:
    Midlands, England
    are you using a Firewall? perhaps the XP default Firewall ?
     
  8. dosprompt

    dosprompt Guest

    No, Looked looked there first
     
  9. Burpster

    Burpster Guest

    i'm at a loss so try these steps and see if it helps!!

    WINDOWS XP SETTINGS

    TURN OFF BUILT-IN FTP SERVER
    1. Log into XP as your administrative account (or as administrator)
    2. Open Control Panel
    3. Open Administrative Tools
    4. Open Services
    5. Find FTP Publishing
    6. Right-Click FTP Publishing and select STOP
    7. Right-Click FTP Publishing and select PROPERTIES
    8. Change the Startup Type drop-down box from Automatic to Disabled
    9. Click Apply
    10. Click OK
     
  10. dav3st

    dav3st OSNN Addict

    Messages:
    74
    found this on the bulletproof f.a.q
    "4) Remove any ip you added to the "server option/multi ip settings" list (leave it empty),"
    maybe you added some ip to this list?

    the link
    http://faq.bpftpserver.com/
     
  11. dosprompt

    dosprompt Guest

    tHANKS
     
  12. dosprompt

    dosprompt Guest

    Thanks for the effort and the intrest BUT sorry to say that did not do the Trick so now were all confused! I even have now closed IIs down but I thnks its email time to the Dreaded MS guys
    thanks again
     
  13. Burpster

    Burpster Guest

    last ditch attempt on my part....why dont you use a port other than 21 for your ftp server.....you have something like 65000 to chose from

    port 21(or whichever you choose) is used for remote commands only i believe ....actual uploads and downloads will use another port altogether

    if i'm wrong feel free to correct me!!
     
  14. dave holbon

    dave holbon Moderator

    Messages:
    1,014
    Location:
    London England
  15. Burpster

    Burpster Guest

    port 21 is only a problem if you allow anonymous access to the FTP as there are alot of ppl looking for this access to use your FTP to store pirated files

    never allow anon. access to your personal FTP.....
     
  16. dosprompt

    dosprompt Guest

    Thanks to everyone for there replys and help
    after switching off FTP and resetting
    Port 21 works BUT I am not able to connect to it SOOO

    I changed to Port 22, that worked BUUUT After connect
    the result error message came back as

    Failed to connect socket

    So the best way I can figure is to put the boot drive for my FTP is Win98se

    and try that

    So thanks again everyone

    Baz
     
  17. leedogg

    leedogg Gojyone kawaiiiiiiii!

    Messages:
    820