PIO / DMA concerning CD Roms

Discussion in 'General Hardware' started by PHiSHnz, Jun 18, 2002.

  1. PHiSHnz

    PHiSHnz Guest

    attached is a screenshot
    of the advanced ata/somethingarather setting
    it's for cd rom
    i always thought DMA was better
    but it gives the option of DMA or PIO for the cdroms
    the os selects the "best" one apparently but yea.. not sure
    just wanna know what it's on about really :)

    look @ the pic anywya.. and reply :)
  2. GoNz0

    GoNz0 NTFS Stoner

    the year 2525
    I just replaced a CD ROM & disconnected my DVD as they were PIO only.

    Access speed suks in PIO
  3. PHiSHnz

    PHiSHnz Guest

    previously i have put it into DMA mode
    but wasn't sure which was best
    i noticed that too
    games took ages to intall
    i might just go put it in DMA now :p

  4. Trev

    Trev Guest

    If i recall right, PIO mode goes 13.3 MB/second... wich is really slow, im not sure wich DMA mode they use, but UltraDMA 100 goes... 100.0MB/second
    I would stick with DMA :)
  5. GoNz0

    GoNz0 NTFS Stoner

    the year 2525
    UDMA mode 2 = 33mb a sec
  6. PHiSHnz

    PHiSHnz Guest

    oh cool :)
    it's on DMA now :)
  7. dreamliner77

    dreamliner77 The Analog Kid

    Red Sox Nation
    I chose DMA for my CD-RW and it won't go. It just stays in PIO. Can anyone give me any suggestions?
  8. maz4ruth

    maz4ruth Guest

    My Plextor 12/10/32A will not use DMA Either, I have the jumper on the back enabled so it should be able to use DMA mode 2...

    Also recently, when I burn a CD my PC really performs erratically, even the mouse cursor jerks!

    I think it's time to format (I have had this installation on since October).
  9. Trev

    Trev Guest

    Do you have burnproof enabled? If you do, when your buffer drops, sometimes it will lag even my computer. (look at my sig) thats usually a normal thing
  10. evilhomer

    evilhomer Guest

    couple options

    you might be able to turn on DMA in your BIOS

    or you might need a new cable for your CD-ROM

    or sometimes, just changing it from the master IDE channel to the secondary works (even though there's no good reason that would ever work)
  11. GraveLayer

    GraveLayer Guest

    I also have a 12/10/32a which won't go into DMA mode. I just figured it was because its "old". I didn't realize it has a jumper on it to enable this though (???). I'll look into this though. I do have mine on its own channel set to master.
  12. maz4ruth

    maz4ruth Guest

    Yeah GraveLayer, the jumper is to the left of the digital audio out, shorten this and DMA should be enabled...

    The thing is, my BIOS recognises it as being enabled, but WinXP won't let me! :confused:

    When I use my my burner, (it's the only drive on it's own channel...) whether for writing or reading, performance is bad.

    I think a format and reinstall is the order of the day ;)

    BTW... I think my problem could also involve VIA's 4 in 1 driver, I'll look into it.