php trouble

Discussion in 'Web Design & Coding' started by Nismo83, Sep 2, 2003.

  1. Nismo83

    Nismo83 OSNN AZN Addict

    Messages:
    383
    i've installed the phptriad 2.11 and everything config went smoothly but when i execute the script... lets say this

    <?php

    $myvar = "Hello World";

    echo $myvar;

    ?>

    the output should be Hello World but it gave me

    HTTP/1.1 500 Server Error Server: Microsoft-IIS/5.1 Date: Tue, 02 Sep 2003 06:49:32 GMT Content-Type: text/html Content-Length: 44 -2147417842 (0x8001010e)

    What happen here?
     
  2. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    Haha, IIS 5.1. :p Have you registered the PHP plugin proberly in IIS? (Start -> Programs -> Administrative Tools -> Internet Services Manager. Expand the websites at your computer and rightclick 'Default Website' or whatever name you gave to your site. Choose properties and click Home Directory -> Configuration. Is PHP in the list? If not, click add. Now browse to the executable, (usually C:\php\php.exe) and add the extension (.php), now click ok. I don't know if you need to restart the computer, but to be on the safe side, do so).
     
  3. Nismo83

    Nismo83 OSNN AZN Addict

    Messages:
    383
    yea... it works.. i;ve added the wrong thing. instead of the *.exe.. i've added the isapi.dll. lol :D
     
  4. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    Weee! Glad it works.