Operating system not found after XP setup

Discussion in 'Windows Desktop Systems' started by Skunk141, Apr 29, 2010.

  1. Skunk141

    Skunk141 OSNN Addict

    Messages:
    98
    Hi chaps, got a really strange one.

    Got a Acer Travelmate 4060 here with a failing hard disk although it does still boot to XP.

    So easy job, change hard disk, and load xp again. Well everything appears to go well, XP setup starts, finds the disk, partitions and formats it then starts copying files, gets to the end when it restarts for the first time and up pops the message "Operating system not found"

    I've tried original XP Home and Pro discs not fiddled with ones. One's that I have tested in another PC I have here and they work fine.

    I've taken the disk out plugged it in to my PC and that also confirms all the files from XP setup are on it and the partition is marked as active.

    Can any one shed any light on this as it's driving me insane!

    Cheers
     
  2. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    Sounds like something may be amiss with the boot order. Do you have a USB stick or something plugged in? My old desktop would assign a USB stick as HDD0 if one was plugged in while booting.
     
  3. Terrahertz

    Terrahertz Extinction Agenda Political User Folding Team

    Messages:
    972
    Location:
    New York
    What Admiral Michael said and also check your bios so that your HDD is first to boot.
     
  4. Skunk141

    Skunk141 OSNN Addict

    Messages:
    98
    Both triple checked many times! Such a weird one, never come across it before, any other clues as I'm suspecting hardware problem although it will still boot from old disk as soon as it's swapped back so that too eliminates wrong bios settings...

    Oh also checked BIOS update but there is none.

    HELP!
     
  5. Johnny

    Johnny .. Commodore .. Political User

    Messages:
    5,015
    Location:
    Happy Valley
  6. Skunk141

    Skunk141 OSNN Addict

    Messages:
    98
    Been through the whole lot and still no joy. Looks like it's dead then, shame as the current drive boots to XP but is dying, strange thing is, I've loaded XP about 5,000 times and I've never seen a PC/Laptop do this.
     
  7. Nuadormrac

    Nuadormrac OSNN Sexual Deviant Political User

    Messages:
    69
    Here's the thing, failing hard disk? Exactly how? Many have suggested checking the boot order and stuff; but I'm going to go out on a limb and suggest that if the HD has given some problems of other sorts, run a 'chkdsk /R' on it.

    If chkdsk comes back and says the format is RAW and it can't check RAW disks, or it returns an error along the lines of "track 0, sector 0 bad"; get the data off that drive asap and replace it. With a used drive, it is not inconceivable that the hard drive might be going bad, as in developing bad sectors. The way that works also is that if some of the sectors start going bad, it's only a matter of time before other sectors go bad also.

    Any idea on the age of the drive? It is concevable that it is trying to boot from the wrong hard drive controller (this can be configured in boot.ini); but it also conceivable that it's having trouble loading. How exactly is this comming up? Are you getting the boot menu for winXP (which would suggest it's getting past the boot sector), or is it booting to this error straight up (what it sounds like you were saying) in which case it can't get beyond the boot sector.

    In the meantime, if you copy the boot loader files to a floppy (on an already installed system) and boot from floppy, the boot sector off the floppy + the boot loader can get it to load off the HDD, assuming something else isn't wrong (aka the OS files are corrupted/perhaps badly saved at present, so can't load).

    As it's a laptop you got, hard to determine if it was an issue before; but if this keeps happening, it is worth testing to the drive to see if it started going bad. I'd definitely start testing hardware at this point.
     
  8. terchi6094

    terchi6094 OSNN One Post Wonder

    Messages:
    1
    I had the same problem with my solo 9500
    all i did was...

    go to bios
    set bios to default settings

    it should be okay after that