No Video, No Keyboard

Discussion in 'General Hardware' started by Marlboro Red, Aug 10, 2003.

  1. Marlboro Red

    Marlboro Red Guest

    I changed a pc133 64 mg chip with a pc133 256 mg on a Biostar M6VCF, and now the system won't boot: the power light turns on, the cd player opens and closes, the hd spins,and the cpu & fan work, but I get no video. The keyboard lights up and turns off when I power up, but other than that, it stays off. The Biostar M6VCF manual says the MB takes up to three 256 mb dimms. I put the 64 mb dimm back, and still nothing. Any ideas?
  2. Hipster Doofus

    Hipster Doofus Good grief Charlie Brown

    Melbourne Australia
    Welcome tot he forums Marlboro Red. :)

    Seeing as it still won't work putting the old memory in try checking all your connections. Maybe a cable got dislodged.
    Also make sure the memory is correctly seated.
  3. Marlboro Red

    Marlboro Red Guest

    I checked the connections with the diagram from the manual, and every thing seems to be in order. I'm going to check it again, and clean the dimm with alcohol. It seems as if the dimm isn't making proper contact but other than pushing on the dimm to make sure it's seated, I don't know what else to try. Any other ideas?
  4. Taurus

    Taurus hardware monkey

    Sacramento, CA
    remove and re-instert the dimm a couple times to help make sure it's getting good contact. also, trying clearing your cmos.
  5. GoNz0

    GoNz0 NTFS Stoner

    the year 2525
    reinsert the video card incase u knocked it.
  6. Zedric

    Zedric NTFS Guru Folding Team

    You may have killed the mobo, graphics card and/or memory with static electricity you know. It's a b*tch, but it happens. :(