nfs folder wont mount yet others will

Discussion in 'Linux & BSD' started by Dark Atheist, Dec 7, 2007.

  1. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    Dec 7 11:41:10 c-8e1471d5 mountd[17193]: Fake hostname host-xxx.xxx.xxx.xxx.speedlan.se for xxx.xxx.xxx.xxx - forward lookup doesn't exist
    Dec 7 11:41:10 c-8e1471d5 mountd[17193]: refused mount request from xxx.xxx.xxx.xxx for /xxxx/xxxx (/): not exported

    is the error i am getting when i try to mount a folder across nfs, strange thing is there are three other folders that have all mounted yet this one cant as it says there is a problem with the host name

    i have checked hosts.allow and hosts.deny - the ip is right in there, i have checked exports file and that is fine.
     
  2. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    after more lokking - seems it may be a fs issue, i have made the file .autofsck in / - so hopefully it will find and fix things, but is that all i need no switches or anything
     
  3. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    its ok looks like its sorted now
     
  4. vern

    vern Dominus Political User Folding Team

    Messages:
    1,571
    Location:
    Minnesota, USA
    So what was the problem?
     
  5. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    dont know - i removed the ip addrees from the exports file then did exportfs -ra , then readded the ip and did exportfs -ra again - worked after that :)