Need help! 2 PC LAN - Desktop sees laptop, laptop doesn't see desktop.

Discussion in 'Windows Desktop Systems' started by CelicaMan94, Apr 13, 2008.

  1. CelicaMan94

    CelicaMan94 OSNN Junior Addict

    Messages:
    27
    I'm reviving and revising this thread. I'll try to keep it short and answer the posts below.

    My desktop is running Windows Vista Ultimate and my laptop is running XP Media Center. I'm still having the same problem as before where both computers can see each other in the workgroup, but only the desktop can access the laptop's shared files and not vice versa. When I click on the desktop in the workgroup from the laptop, a window appears asking for a username and password. I have no user accounts with passwords set on either computer and don't desire to set one. File sharing is enabled on both computers, Defender is disabled on the desktop and the laptop is running Windows Firewall. I have no admin passwords on either computer. Trying to access the desktop using Desktop\Administrator (which has no password) I get the usual "not accessible" error message saying the account is currently disabled.
     
    Last edited: Jun 10, 2008
  2. Petros

    Petros Thief IV

    Messages:
    3,038
    Location:
    Pacific Northwest
    Is this thread describing what's going on? If not, try uninstalling software firewalls and see if that does it.
     
  3. jczr2

    jczr2 OSNN Junior Addict

    Messages:
    10
    Location:
    NJ
    what works for me well on my home network, is having the admin password the same on both machines. That always gave me the least amount of problems on my own network.
     
  4. JPRuss

    JPRuss OSNN Addict Folding Team

    Messages:
    77
    Location:
    In the unknown
    Do both machines exist in the same workgroup? Is one a member of a domain?

    It does make things easier if the Admin password on both machines is the same.

    Let's say the name of the Laptop is LAP01, and the Desktop is DESK01.

    If you are prompted for the username nad password on the Desktop from the laptop. Try enting DESK01\Administrator and then the Administrator password that is on the DESK01 machine.

    If that fails, then I would expect the Desktop shared folders did not setup the proper file permissions. If it is XP PRO, you should be able to right click on the shared folders and manually change the file permisions (and share permissions) to grant full access to the approperiate user account.

    Hope this helps.

    [​IMG]
     
  5. roirraW "edor" ehT

    roirraW "edor" ehT Builder/Installer

    Messages:
    529
    So what happens if you enter the desktop's username and password?

    Also, when you use the Network Setup Wizard, it automatically turns on XP's firewall at the end, which I don't think is your problem, however if you already have a different software firewall, you should turn XP's built-in one back off because you should never have more than one software firewall running at the same time.

    To turn off XP's built-in firewall, go to Control Panel and open Network Connections. Next, right-click on your network connection (if you have more than one, it shouldn't matter which one you choose) and choose Properties.

    Choose the Advanced tab at the top and click Settings. Select Off (this is completely safe as long as you have another firewall running) and click OK, then OK again, and you can close Network Connections and the Control Panel. This will turn off XP's firewall for all of your network connections.
     
  6. Basekid

    Basekid OSNN Junior Addict

    Messages:
    13
    Do you have a password on both computers when you log in? I had the same problem as you (with a password popup) and for me it stopped after I put a password on the computer(s).
     
  7. CelicaMan94

    CelicaMan94 OSNN Junior Addict

    Messages:
    27
    And bump after the edit.