My shut down takes forever

Discussion in 'Windows Desktop Systems' started by Fig, May 7, 2002.

  1. Fig

    Fig Guest

    On shutting down xp my desktop sits looking at me for many minutes. Does anyone have any hints on how to speed up this process...? How can I see what is taking the time? (I guess it is a service)
     
  2. TuMbRaS

    TuMbRaS Guest

    shutdown...

    Are you using any 3rd party applications that "clear pagefile at shutdown"??? if so, that will increase your shutdown time considerably....

    and if im not mistaken.. there IS a way to manage your shutdown procedures....

    probably by getting into "startup/shutdown" tab and/or
    typing in gpedit.msc at your run box and hunting around in there. i would normally tell you how to do it..but i dont have an XP box in front of me..sorry.. but let me know how you manage....


    ~n :D
     
  3. Fig

    Fig Guest

    Yeah thanks for the info... No third party software that clears the pagefile. Looking for something that will show the service that is waiting and delaying the shutdown process...

    Or any hints from XPerts that have faced the same problem...
     
  4. GoNz0

    GoNz0 NTFS Stoner

    Messages:
    2,781
    Location:
    the year 2525
    << aint no expert.... but.. do you have norton anti V running, if so is it trying to scan a drive on shutdown, caused me a long shutdown until i disabled it.
     
  5. SeNTiNeL

    SeNTiNeL Guest

    Try using the file BOOTVIS.EXE from Microsoft.

    This will increase the boot and shutdown performance.
     
  6. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Messages:
    5,518
    Location:
    England
    in reg go to hkey_current_user->control panel->desktop

    change the WaitToKillAppTimeout and HungAppTimeout to something like 200 (or lower)
     
  7. Fig

    Fig Guest

    Tried BootVis ... It was great for Boot optimizing.... Unfortunately it did not do much for shutdown!....

    Timetokillapp was great for apps hanging around but again it didn't kill the services hanging around.

    No... There must be a shutdown viewer out there somewhere and an eXPert knows about it....

    Anyone with an idea...??? Please...
     
  8. Khayman

    Khayman I'm sorry Hal... Political User Folding Team

    Messages:
    5,518
    Location:
    England
    Hkey_Local_Machine/system/controlset001/control

    then change waittokillservicetimeout to 3000 or 4000 or whatever
     
  9. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    Messages:
    12,332
    Location:
    new york
    this is not my tweak, I never tryed this, and I''m not indorsing it, s.I havn't tryed it, or know anyone who has, I just read it, so backup first;

    Go to Start -> Run and type "regedit". Navigate to "HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control" click on the "Control" folder In the right window you will see this key "WaitToKillServiceTimeout" Double click that key and set it to a value lower than 2000.
     
  10. allan

    allan Guest

    BootVis has nothing at all to do with shut down. It simply reorders the services and programs that load when you boot for maximum load time efficiency.

    Are you on a network? If so, the network protocols do take a little time to unload.

    If you want to accurately identify what's holding up the shutdown, here are two methods from which to choose:

    1) The better but more time consuming is a selective startup. Go to msconfig and disable everything then boot and shutdown. If the shutdown process is faster, start adding items back in msconfig one at a time until the shutdown problem recurs - then you'll have identified the offending service or program.

    2) Quicker but potentially less effective - go to task manager and kill the running aps / services one by one before shutting down and see if that reveals the culprit. Only problem with this method is that if it is a service it may be grouped in with others in an svchost. In that case, you can download and use Process Explorer to identify dependencies and affiliated processes.

    The tweak Dealer mentions above this post may indeed be helpful depending on what's holding up the boat, but you should be aware of one potential problem: if XP shuts down without sending proper notification to certain services, there is a possibility of creating corrupted data stores. Adimittedly this is not a likely occurance and I'm not suggesting it isn't a potenntially valid solution, but the possibility for trouble does exist.
     
  11. ChrissiCom

    ChrissiCom Guest

    I have Norton Antivirus 2002 running and also I activated clear pagefile at shutdown (with Tweak XP) and shutdown still takes less than 30 seconds... my pagefile is 300 MB. So these two things should normally be no problem.

    Try to run "services.msc" and disable all COM+ applications they are not needed usually and suck up a whole lot of time when booting and shutting down. Also try to keep your page file smaller than 400 MB (what windows xp says is a good size is stupid because it suggest more than 570 MB for the page file although I have 512 mb ram). I have the Kill app and service time set to 200 msec which should be enough. If this still does not solve your problem run the task manager and see if any programs are running which are not in the usual run folders or started by you, just look up from where they are started and kill'em :)
     
  12. Fig

    Fig Guest

    Folks... Thanks for all your input. My checking of services operating was done using Task Manager. After firing up MSCONFIG and checking out the services that were running and then checking the non ms ones guess what I found? Yep... The old NVIDIA helper service. Kicked that one out (didn't see it in the task manager) and everything zings along...

    NVIDIA sure make great chips 'n drivers but I think they need help with their "helper" proggys!