(Mess)enger 6 Login Fix

Discussion in 'Windows Desktop Systems' started by TheBlueRaja, Jun 30, 2003.

  1. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    I have windows messenger and Norton Antivirus / Firewall installed on my PC, but the problem i have is that Messenger always tries to load first, and because Norton stops all traffic until is running, it never signs in automatically and just stops.

    So does anyone know how to make messenger wait until norton is loaded before it attempts to login?

    Thanks..;)
     
  2. Geffy

    Geffy Moderator Folding Team

    Messages:
    7,805
    Location:
    United Kingdom
    actually Norton kills the Connection that Messenger is trying to make when it starts. But I know what you mean, and I havent found a fix for it yet
     
  3. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Norton Kills it? WT.... :confused:

    So does that mean that if norton is killing it and NOT just stopping all network traffic before loading (as i thought). Because it would just be a case of setting up a rule then.

    But we already have a rule for Messenger otherwise it wouldnt work at all.

    Unless....

    Messenger uses different ports when logging in, but, it cant coz,
    hmmm, :thinking:, well it wouldnt log in at all..

    Im gonna check the blocked connections in the log.

    Are you sure Geffy?
     
  4. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Whoooo....

    Your right Geffy - and i've fixed it too.... Thanks.

    If you want messenger 6 to login correctly at startup follow the following procedure. (Norton Firewall 2003)

    Open Norton Firewall and click Personal Firewall and click the Configure button that appears on the right.

    Select the Advanced Tab and Click the button which states "General Rules".

    Now the rule that is stopping Messenger working at login is the rule for "Block access to Secure sites" which you can see if you scroll down the list. Now you dont want to disable this, what we need to do is set up a new rule specifically for messgener that will allow it to connect at login.

    So click the "Add" Button. On the next screen make sure Permit is selected and press the next button. On the "What type of connections do you want to permit?" screen select "Connections to other computers" if it isnt already and hit Next.

    Now click the selector next to "Only computers and Sites Listed Below" and the "Add" button, which was previously greyed, should now be available to click. Click "Add" and in the screen that appears put in the following details

    loginnet.passport.com

    and press OK. The window will dissapear and you will see the following :-

    Single Address IP : loginnet.passport.com

    When thats done, Click "Next" to move on a screen. Now where is says "What Protocols do you want to Permit" select TCP. And below this where it says "What types of communicatios, or ports, do you want to permit?" select the check box that says "Only the types of Communication or ports listed below". Again the "Add" Button will become available, click it and scoll down on the screen that pops up to, "443 HTTPS aka MCom", and check the box next to it, and select OK.

    Click "Next" again and in the following window, you can select "Create an Event Log" if you want (not really necessary) and click the "Next Button" Now call it something like "MSN Messenger Allow Rule" and select "Next" again. You will then get a screen which summarises the rule you have just configured, click "Finish".

    This will then create a Rule for messenger - but were not done yet.

    At the General Rules window (where you should now be) scroll right to the bottom of all your rules. This is where your new rule will be. Highlight it by clicking on it and press the Move Up Button continuosly until it is above the "Block Access to Secure Sites" rule.

    Now click Ok and come out of Norton. Now next time you load - Whoot - messenger logs in...

    Easy.. (Ahem!)

    :D

    Hope this helps...
     
  5. Geffy

    Geffy Moderator Folding Team

    Messages:
    7,805
    Location:
    United Kingdom
    yep, I noticed this when I would disable my firewall with MSN running it would be fine, but when I re-enabled the firewall, MSN could get disconnected, glad you got it fixed now

    gonna go do this to mine now :p
     
  6. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Let me know if it works for you too.

    ;)
     
  7. sboulema

    sboulema Moderator

    Messages:
    2,846
    Location:
    Amstelveen, The Netherlands
    TheBlueRaja thanks for this piece of info.
     
  8. Geffy

    Geffy Moderator Folding Team

    Messages:
    7,805
    Location:
    United Kingdom
    BTW why did you choose that IP address to allow?
     
  9. Geffy

    Geffy Moderator Folding Team

    Messages:
    7,805
    Location:
    United Kingdom
    ah thats loginnet.passport.com :p
     
  10. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Haha,
    If you want to check it - Go into Norton Firewall and Statistics on the Left Hand side.

    This will give you three buttons - Click "View Logs"

    In here you will find all the logs for your firewall - but if you select the "Firewall" option in the sidebar you will see all the logs for the rules in your firewall.

    Somewhere in here you will see something like

    Rule "Block access to secure sites" blocked (loginnet.passport.com(65.54.226.247),https

    The IP Address shown here is the one i have allowed.

    Incidentally, i have just noticed that it checks different servers when trying to log in (not just 1), trying another one each time until it gets one it can log into (Presumably if any are down).

    I will update my post above with the IP Addresses and Any more i find that messenger uses.

    Good luck...

    :D
     
  11. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    :eek:

    Actually - you dont need all the Ip Addresses - Just use the URL instead of the Ip Address and it works the same...

    So use:-

    loginnet.passport.com

    Instead of the IP Addresses which were in my original post (until i edited the post)

    Sorted...