maxtor speed DMA

Discussion in 'General Hardware' started by surfer, Mar 13, 2002.

  1. surfer

    surfer Guest

    First my specs:
    AMD athlon 1 ghz
    512 mb memory
    Nvidia MX video
    Abit KT7a RAID motherboard with VIA chipset
    Onboard Highpint controller
    winxp pro

    Problem:
    Two weeks ago i attached a maxtor 40 GB harddisk to the IDE connector at the highpoint controller of the mainboard as a master. The slave is a identical drive with support for UDMA5.
    Winxp doesn't see the drives as UDMA5 drives but as PIO mode 4 drives. The option is set to use DMA if available.
    When i do a speed test with sandra2002 the result is the half of a dma33 rive 30GB!

    When i look at the information in sandra2002 the maxtor drives are under the section: ATA/ATAPI information and the current status is PIO MODE 4!!
    The cdrom and CDRW wich are connected to the IDE1 and IDE2 both as master connected are under the section: SCSI information. This is strange but i am sure that the drive are properly connected with a 80 pin cable. There is no doubt about it.


    How can i change this?

    Thanks,
     
  2. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    I've read of alot of problems if your trying to connect the HD to the RAID controller but not as a raid setup, does the harddrive work in UDMA 5 mode if it's connected to the normal ide inputs?
     
  3. surfer

    surfer Guest

    maxtor problem speed

    I have not tried that yet. This is because than i can not profite for the complete ata 100 i suppose.

    Another suggestion?

    There are many more users who have this problem in xp. I visited many other forums but nobody has a correct answer. There are users however who can make the best speed with this drive and winxp, so it must work somehow??
     
  4. krisatkins

    krisatkins Guest

    Pio mode blues

    I don't know if I can offer any assistance or not, but I am having a similar problem with my cdrw. One thing I did try which didn't work for me, but might work for you is to use the Via IDE tool v3.3, do a search for it on the forums, as I can't remember the url.
    It fools your devices into being SCSI drives and might bring your transfer rate back up. I hope this helps a little.
     
  5. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    Re: maxtor problem speed

    sorry, I don't follow when you say you can't profite(sp?) for the complete ata 100?
     
  6. stapler101

    stapler101 Guest

    I run an abit kt7araid, not probs. What are the bios settings? When you first boot use (I think) alt h to set hd to udma etc.
    I have hd as master on ide 1, cd on 2 as master, and burner on 3 as master.
    It is ctrl h, not alt h.
     
  7. surfer

    surfer Guest

    I know, the bios says it is a UDMA5 disk, now i flashed it but this doesn't effect it. The bios now says i have a ATA 100 drives attached to it wich is the same as UDMA 5.

    Sandra still say it is in PIO MODE 4 in winxp. The benchmark says 13000 this is still to slow, much to slow.
     
  8. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    Surfer,

    where do you have each cable plugged and and what master/slave settings.
     
  9. surfer

    surfer Guest

    master IDE 3 (=port at Highpoint controller): maxtor 40 gb
    slave ide 3maxtor 20 gb
    master IDE 4: maxtor 40 gb D740 (UDMA 133)

    IDE 1 DVD pioneer 116
    IDE 2 Plextor 16 x writer

    There are 2 80 conducter cables attached to the IDE 3 en 4.



     
  10. Qumahlin

    Qumahlin Moderator

    Messages:
    2,006
    Are you trying to run raid? because if you aren't I'd recommend connecting your HD's to IDE 1 and 2 and try connecting the drives to the IDE 3 and 4.

    See if that allows you to get all the drives in DMA mode. The raid ports aren't any faster then the other ide ports so putting the cd drives there and the HD's on the standard IDE shouldn't effect performance other then possibly getting the drives to work

    My friend has the same board and the only way he could get the drives to run in DMA 5 like they should was to set it up as raid, or just move them to the normal ide ports...he chose to move them

    so try that and see if it works.
     
  11. Static 99

    Static 99 Guest

    Surfer

    I don't know if this is any kind of help, but when i changed the "VIA Bus Master IDE Controller" to "Standard Dual Channel PCI IDE Controller" my drive speed went up from DMA mode 3 to DMA mode 4.