m0n0wall, WRT54G, and a headache

Discussion in 'Linux & BSD' started by jasonxjason, Oct 9, 2008.

  1. jasonxjason

    jasonxjason OSNN One Post Wonder

    Messages:
    3
    I wasn't sure where to put this thread, if this isn't the right place, I beg forgiveness and politely ask a moderator to move it wherever it should be.

    My current network setup is as follows. I have a m0n0wall hardware box with two NIC cards, one for the LAN and one for the WAN. The WAN port on the m0n0wall goes directly to the modem provided by my ISP. The LAN port on the m0n0wall goes to a large 64 port switch, which all of the computers are connected to.

    Now, I'm trying to set up wireless and having an absolute nightmare of it. I have a Linksys WRT54G wireless router, which I want to plug into the switch and use only as an access point. What I really liked about my m0n0wall setup when I started was how easy it was, which is great, because when it comes right down to it, I honestly don't know much about networking. I simply can't manage to line up all the variables correctly to get this stupid thing to work.


    My m0n0wall setup, which I'd prefer not to change (but I'm easy):

    [​IMG]

    [​IMG]

    Linksys Config Screen:

    [​IMG]

    All of my computers can see the m0n0wall at 192.168.1.1, and all my computers can see the WRT54G at 192.168.1.165. As the WRT is set up now, as you can tell from that screen, it obviously cannot see anything. At one point I had it so the WRT could ping the m0n0wall at 192.168.1.1 and get a response, but the m0n0wall still couldn't see the WRT, and those settings got lost with my tinkering.

    The wireless is active and working, but computers who connect to the WAP obviously cannot see anything but the WAP itself.
     
  2. Dark Atheist

    Dark Atheist Moderator Political User Folding Team

    Messages:
    6,376
    Location:
    In The Void
    do you mean you want to use the wireless for just the lan or for both wan and lan ?
     
  3. Johnny

    Johnny .. Commodore .. Political User

    Messages:
    5,015
    Location:
    Happy Valley
  4. LordOfLA

    LordOfLA Godlike!

    Messages:
    7,027
    Location:
    Maidenhead, Berkshire, UK
    you need to fill in static IP details on the wrt too :)
     
  5. X-Istence

    X-Istence * Political User

    Messages:
    6,498
    Location:
    USA
    Usually when I have an WRT54G that I need to add to an existing network I turn off the DHCP on the WRT54G, set it to a static IP address, and then plug a cable into the switch part of the wireless router, and not the WAN port. Now it should act as a standard wireless access point that will let people connect, and get DHCP addresses from your M0n0wall DCHP server.

    As soon as you plug from the switch into the WAN part of the WRT54G it will want to do routing/NAT. Which is exactly what you don't want. You may be able to turn that off in the advanced options, I am not entirely sure. I don't have one lying around my house anymore!
     
  6. the_tazinator

    the_tazinator Are we there yet?

    Messages:
    177
    Location:
    In a house
    This is actually the exact same thing that I am running. M0n0wall as my main router and a wrt54g with dd-wrt firmware as my access point (NOT a router). My question is from the wrt54g, what port are you using to connect to the switch, the WAN port or one of the other 4 LAN ports? My suggestion is to connect it to one of the "LAN" ports rather than the WAN port. This will allow the WAP to work like a switch rather than a router. The wrt54g should be configured with a 192.168.1.? ip address configured for tha LAN (I suggest something like 192.168.1.2 to keep it simple and not to conflict with the DHCP range) with a gateway of 192.168.1.1 and DNS of 192.168.1.1. Disable DHCP server since monowall will be doing DHCP for the LAN. Configure your wireless and you should be set.

    If you need help creating the config for either the wrt54g or the monowall I can create a sample config file and send it to you.
     
  7. jasonxjason

    jasonxjason OSNN One Post Wonder

    Messages:
    3
    Thank you, however I don't know what to put for the first entry, "Internet IP Address". It seems to me like it should be the same value, but it won't let me do that. -_-

    [​IMG]
     
  8. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    Connect to LAN port, DHCP in wireless router truned off.

    Also, make sure the internal IP of the WRT54g is not the same IP as the modem or the computer running as the router (this can happen with some brands). I set my access point to a very high number IP.
     
  9. X-Istence

    X-Istence * Political User

    Messages:
    6,498
    Location:
    USA
    You should leave those to all 0's. That configuration is for the WAN port and since you will not be using that you don't need to touch it.

    Just set the devices IP address to 192.168.1.?. Like you have. DHCP off, and you should be set!
     
  10. jasonxjason

    jasonxjason OSNN One Post Wonder

    Messages:
    3
    Thanks, everybody.

    It turned out the real cause of my problem was far more facepalm-inducing. I was setting up the WAP for my Wii, and as I had no need for wireless before my Wii, I also had nothing else to use to troubleshoot the connection. It turned out the WAP was working just fine all along, I simply had to forward ports specific to the Wii before it could establish any sort of connection.
     
  11. Johnny

    Johnny .. Commodore .. Political User

    Messages:
    5,015
    Location:
    Happy Valley
    I am glad you got it working ...
     
  12. Admiral Michael

    Admiral Michael Michaelsoft Systems CEO Folding Team

    Hmm, I didn't have to forward any ports for my Wii to work. Altho I use SmoothWall so maybe it's different.