Lost icon in My Computer window

Discussion in 'Desktop Customisation' started by MilanSt, Mar 9, 2002.

  1. MilanSt

    MilanSt Guest

    All user on my XP exept administrator have lost My Documents icon i My Computer window. The directory is working fine, only icon is missing from My Computer. Icons that are visible in My Computer are Shared Documents and harddrive icons.
    What should I do to make the icon reapear?
    Ìèëàí
     
  2. gajef

    gajef OSNN Addict

    Messages:
    76
    the "to show/hide 'My documents' on the desktop" option can be set when you go to the control-panel/display/desktop under customize desktop you can set/hide 'My documents' :)

    If this option is greyed out and your computers are on a domain:
    somebody has tweaked the group-policy :(
    How to change this depends on what kind of domain you are on (w2k / nt4)

    Hope this is helpfull

    Gert-Jan
     
  3. MilanSt

    MilanSt Guest

    Problem is not the icon on the desktop. That works fine.
    Problem is that I do not see My Documents icon when I open My Computer. There are three rows of icons:
    - Files Stored on This Computer
    - Hard Disk Drives
    - Devices with Removable Storage

    The first row used to have two icon: Shared Documents and My Documents but now there is only Shared Documents icon.
    That is the problem.:(
     
  4. tkole

    tkole Guest

    Here is the fix.

    WORKAROUND
    WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

    To work around this problem if the computer is already in this state, manually add the registry entries. To do so, use Registry Editor (Regedt32.exe) to locate the following key in the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DocFolderPaths

    Add the following registry value, and then quit Registry Editor:
    Value name: user name
    Data type: REG_SZ
    Value data: user profile\My Documents

    Replace the user name and user profile environment variables with the literal values for each user who logs on to the computer.

    NOTE: In each user's My Documents folder and subfolders, open the Desktop.ini files and modify the Owner value under the "DeleteOnCopy" section to match the user name.