Logitech MX 700 Mouse

Discussion in 'General Hardware' started by Gary Pandher, Apr 26, 2004.

  1. Gary Pandher

    Gary Pandher Moderator

    Got no idea why but now evertime i put the mouse in its base thing to charge the batteries..the base doesn't seem to detect that the mouse is there..and it wont charge the battery either anyone know why this might be..the lights on the base appear but for like caps lock num lock n stuff like that..but if i put the mouse on the base it does not recharge
  2. redman

    redman OSNN One Post Wonder

    I had the same problem mate so i cleaned the contacts and you heve to ...sorta wiggle the and push the mouse in the cradle with a bit of a force sounds strange but it worked for me ......
  3. dreamliner77

    dreamliner77 The Analog Kid

    Red Sox Nation
    Don't have one of those, but suggestions:

    Break out the Isopropyl Alcohol and Q-Tips and clean the contancts. Sometime a needle or pin can be used to scrape some of the crud off.

    If they are spring loaded contacts, try using the needle to pull the contacts up/out a bit.
  4. indyjones

    indyjones OSNN.net Adventurer

    yeah i have one but never any problems, i would suggest that its a contact problem. Also check the power adapter is plugged into the usb plug properly
  5. RazerBack

    RazerBack The First Rebirth

    I had the same problem with my MP3 player, I replaced the rechargeable AAA batteries that it came with, with the same type of batteries. Everything worked fine after that.