Linux finds eth0, but yet no eth0?

Discussion in 'Linux & BSD' started by Zedric, Jan 12, 2005.

  1. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    I have a slight problem with my NIC. It's an onboard NIC (RTL8100) stuck on an Abit BD7II-RAID motherboard. When I try to install Gentoo (or run Knoppix for that matter), the NIC is detected and the system tries to get an IP through DHCP. The problem is the NIC won't light up. When I run ifconfig, eth0 isn't listen, only lo. If I run net-setup (on the Gentoo cd) eth0 turns up, but without and IP and with zeroed stats. Still no lights.

    If I check the modules, the rtl8139too driver is loaded as it should be (it's the right one, right?), so apparently it did detect the card.

    I know the NIC is ok, the current Windows XP installation uses it and has been for two years.

    Any ideas? I'm no Linux expert of any sort, so I'm not at all sure what to do next. :(
     
  2. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    That's funny, I had the same problem, but that was because I used the wrong cable (Internet --wireless--> Win ME machine --wired--> Linux laptop), I needed a crossover and I used a straight through. Weird shiz, the network.

    Anyway, sorry I don';t have a solution to your problem :p
     
  3. X-Istence

    X-Istence * Political User

    Messages:
    6,498
    Location:
    USA
    As root, run:

    killall -9 dhclient

    dhclient -vvv eth0

    Then see if it says any errors.

    You can also bring the interface up yourself with an IP:

    killall -9 dhclient

    ifconfig eth0 "inet <some IP address not on your network, which your router routes> netmask 255.255.255.0"
    ifconfig eth0 up

    route add default <your router ip>

    If this does not work, then i am sorry, but Linux is not my favorite OS.
     
  4. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    after running net-setup issue this command:

    dhcpcd eth0
     
  5. Glaanieboy

    Glaanieboy Moderator

    Messages:
    2,626
    Location:
    The Netherlands
    Hey, now I know finally how to dhcp with my linux! I was f0cking around with ifconfig, but it seems I was all wrong after all.
     
  6. j79zlr

    j79zlr Glaanies script monkey Political User

    Messages:
    2,725
    Location:
    Chicago
    That would really only work if you have the dhcp client daemon installed. It is just a work around for the installation, after it is installed, setting up DHCP should be as simple as just editting /etc/conf.d/net to include iface_eth0="dhcp" Different for every distro.
     
  7. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    I tried static IP and all, but it didn't work. I managed to solve it now though. I turned off APIC support in BIOS yesterday, which didn't help. But today when I started it suddely worked. It seems I had to turn the computer off after doing the APIC setting, not just restart it. It's the only reason I can find right now anyway. Strange shiit. :D

    Now I'm going to install Gentoo, wish me luck! ;)