JPG always = JPE

Discussion in 'Windows Desktop Systems' started by morpheus2k, Apr 11, 2002.

  1. morpheus2k

    morpheus2k Guest

    Call me old fashioned, but I (and my porn-hound husband), like JPG's to actually save as .jpg, and not this "new" .jpe

    I'm sure someone knows how to change the registry? or whatever to make JPG's actually save as what they are, and not what XP would like them to be...

  2. morpheus2k

    morpheus2k Guest

  3. M700Police

    M700Police Guest

    I too would love the answer to this. Its driving me nuts.
  4. damnyank

    damnyank I WILL NOT FORGET 911

    Petal, Mississippi
    Am I missing something here???

    I just checked the photos I have saved off the net (both porn and joke type pictures -stored in various folders in "my documents") and digital photos I imported from cd's from my old puter and also scanned items and they are all JPEGs?

    They are shown as JPEG file types using an icon for Photo Studio 2000.

    I don't know why they are this way - I have to guess that somewhere I have something checked to make this the default program. They open with this program and I can also preview them with this program.

    Sorry - don't ask me how I did - I guess it was a default!!

    Hope this info may help some of you who are smarter than I am at figuring this stuff out!
  5. Deszaras

    Deszaras Guest

    I am having the same damn problem.
  6. Tiny Turtle

    Tiny Turtle Guest

    dy, if you right-click on a jpeg image in Internet Explorer (at least in my Swedish 6.0) and choose "Save image as" the filename suggested in the dialog box ends with ".jpeg", not ".jpg". This happens even though the file type is set to "jpg". Try and save the XP-erience logo at the top of this page on your desktop. The file is called "logo.jpg" but XP wants you to save it as "logo.jpeg". Don't rename it and just click on "Save" after chosing the proper place to save it. Now repeat the process and notice how the image you just saved isn't displayed in the list of files as XP thinks it's a different file format and not jpg.

  7. damnyank

    damnyank I WILL NOT FORGET 911

    Petal, Mississippi
    Am I smoking something funny?????

    When I right click on a picture/logo/whatever in internet explorer - I don't see any "save image as" - I get and use "Save Picture as" - that and about 7 other options - such as print picture, properties, e-mail picture, set as background, set as desktop object, and a couple of others!

    I am missing something here???? See my post above!
  8. Deszaras

    Deszaras Guest

    I get "Save Picture As" and the default is ALWAYS .jpe

    Windows will then not recognize it as a JPG after you save it. I can change the extention when saving, but that's a pain in the ass.
  9. damnyank

    damnyank I WILL NOT FORGET 911

    Petal, Mississippi
    Upon clicking on "Save Picture as" - my next window is defaulted to JPEG - with the only other choice being Bitmap

    I'd bet it has something to do with that Photo Studio 2000.

    I vaguely remember something like this going on in my Windows 98 except it had something to do with the program you opened the pictures with!

    Sorry I am not being much help!
  10. Static 99

    Static 99 Guest

    I found this somewhere.

    The images in this archive are all in jpg [JPEG - Joint Photography Experts Group] format. The National Imagery Transmission format [NITF] standards have been designated by the US intelligence community for the exchange of digital imagery, and JPEG serves as the still imagery compression standard in the NITFS suite.

    The JPEG designed an image compression methodology based on the Discrete Cosine Transform algorithm -- the file format itself is now commonly referred to as JPEG, and usually carries the extension .JPG or .JPEG. JPEG is a lossy algorithm -- the compressed image differs from the original, which allows for greater compression ratios. The Discrete Cosine Transform algorithm was designed to make these losses in quality difficult to notice. Depending on image type and compression amount, it can be very difficult for a human to tell the difference between the original and compressed images. JPEG Compression does very well on natural sources such as photographs. Artificial sources such as line art usually display visible pixellation and quality loss when compressed by JPEG.

    There are a number of benefits of using JPEG, in particular the superior JPEG compression algorithms and their better performance with respect to those of Tape Format Requirements Document (TFRD) DCT. Studies based on imagery analyst (IA) analysis on DCT, JPEG, and other Bandwidth Compression/Expansion (BWC/E) algorithms indicates that at equal levels of bit per pixel compression rates, reconstructed DCT and JPEG images are of equal quality on a range of scenes from three different image sources.

    The Central Imagery Office [CIO] has chosen JPEG as the still imagery compression standard for the United States Imagery System [USIS] architecture because the wide commercial acceptance of the ISO standard, coupled with its good imagery quality, will enhance interoperability. The Intelligence Community (IC), DOD, and other agencies have a large installed base of JPEG capable systems, though there are some high-end systems in use which may be expensive to convert.

    Compared with commercially pervasive formats, such as GIF and TIFF, JPEG images typically require anywhere from one third to one tenth the badwidth and storage capacity.

    But what is .jpe ???
  11. Tiny Turtle

    Tiny Turtle Guest

    jpe is still a JPEG image. Somehow Windows decides that a suffix (the stuff behind the dot) is only to be three characters long (I think you can toggle this somewhere). It therefore removes the "g" at the end when trying to save a JPEG image with the suffix ".jpeg" and you end up with a file called "filename.jpe" which some people's systems don't recognize as JPEG images.
    If XP/IE could be set to try and save the files with the suffix "jpg" all of this commotion could be avoided.

    The picture/image confusion was caused by me using a Swedish XP which actually says "Spara bild som" but since you probably don't use a Swedish system I tried to translate it and made a wrong guess what the original choice of words were. This has nothing to do with PhotoStudio 2k. IE just makes it possible to save the image as a "raw" Bitmap/bmp file if you for some reason would like this.
  12. morpheus2k

    morpheus2k Guest

    To end some confusion...

    Tiny Turtle
    JPE = Windows Fax and Picture Viewer file.

    JPG = JPEG, and EITHER of these extensions would be fine with me, but not the JPE, which is NOT a standard JPEG extension, but can be opened with standard programs for editing. Windows has no problem with 4 letter extensions, though TT's idea that windows "crops" the files would be ok, if this particular file wasn't a type recognized by the system. Doesn't matter if the original file has 3 letters in the extension or 4 - they ALL save as JPE, if left to their own devices.

    In MY installation, I have both Photoshop and PSP installed, but the default viewer for JPE files is the built in windows viewer. Both Photoshop and PSP understand the file format.

    You can manually change the extension while saving a file - someone mentioned the logo above. When I (right click the logo above, (or hover and wait for the "image bar"), and select "Save Picture As", this particular file is thus in the save dialog box:

    File Name: logo.jpe
    Save as Type: JPEG (*.jpg)

    Notice it added the file extension into the file name. You CAN change it to logo.jpg (or logo.jpeg), however You prefer.
    But let's take the smilies, to the side on the Reply to Post page - Right click on it, and you have this:

    File Name: redface
    Save as Type : GIF (*gif)

    Now notice that XP did NOT add the extension, but does so as it is saving.

    I don't know how relevant this is, but just something I noticed.

    I do not know what to do. Maybe if we all hit Microsoft with a "WhatDaUck?", we might get an answer...
  13. Static 99

    Static 99 Guest

    Let's pray it'll never play a trick with .html, i guess .tml would be kind of a problem :D
  14. morpheus2k

    morpheus2k Guest

    It does - but it just knocks off the "L", unless you add it (the extension) as html...
  15. morpheus2k

    morpheus2k Guest

  16. morpheus2k

    morpheus2k Guest

    Found a fix?

    Started looking around, and found this on Microsoft Communities:

    And the answer:
    "Neil Golstein" <> wrote in message

    That's not the normal behavior. Normally the extension .jpg is associated
    with jpeg files.

    If you know how to use regedit, navigate to the key
    HKEY_CLASSES_ROOT\MIME\Database\Content Type\image/jpeg

    Check the name "Extension" in the right pane, it should be of type REG_SZ,
    with Data ".jpg" if not double click it and type in .jpg

    If you don't have this key at all or if you don't know how to use regedit,
    copy and paste the following text into a new file and name it


    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\image/jpeg]
    "Image Filter CLSID"="{607fd4e8-0a03-11d1-ab1d-00c04fc9b304}"

    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\image/jpeg\Bits]

    Then double click on the file to import it into the registry.

    If you already have this key, or that doesn't fix the problem, there may
    something wrong with your ie installation. To fix, right click the file
    C:\WINDOWS\INF\ie.inf and select "Install" this will "repair" your ie
    installation. You will need to search your hard drive for a few files as
    the procedure works through.


    I am a coward. I hate playing in the reg - anyone want to try it out and tell us if it works?
  17. Deszaras

    Deszaras Guest

    Nope, it didn't fix mine!
  18. morpheus2k

    morpheus2k Guest

    Sorry it didn't work for you - 3 people over in the Microsoft Communities forum used it, and were very happy with it...

    ANyone else wanna try?
  19. Deszaras

    Deszaras Guest

    I'm about due for a reformat anyway, but thanks for your help regardless!
  20. Mr Breaker

    Mr Breaker Guest

    Maybe you're just too picky? :dunno:

    Like DamnYankee I've no clue why it's doing that to your system. I checked all my files and they seem to appropriate.