Internet tweaks Help

Discussion in 'Windows Desktop Systems' started by flairdevil, Jun 13, 2002.

  1. flairdevil

    flairdevil Guest

    Hi! Need some advice.

    Used Speedguide tweaks to try to increase speed. Speed guide tweaks used to work for my com, Used to get higher values for rcv window limits. But after reinstall of x.p, the rcv values seem to be stuck at a low value even after tweaks from speedguide at the values shown below.
    Only the rwin scaling(rfc1323) is changed from 0 to 2. Even when at windows xp default. the values are as below. Any advisw?

    Using motorola sb4100 usb cable modem.
    ------------------------------------------------------------------------------------
    TCP options string = 020405b40103030201010402
    MTU = 1500
    MTU is fully optimized for broadband.
    MSS = 1460
    Maximum useful data in each packet = 1460, which equals MSS.
    Default Receive Window (RWIN) = 1460
    RWIN Scaling (RFC1323) = 2 bits
    Unscaled Receive Window = 365
    RWIN is a multiple of MSS
    Other values for RWIN that might work well with your current MTU/MSS:
    513920 (MSS x 44 * scale factor of 8)
    256960 (MSS x 44 * scale factor of 4)
    128480 (MSS x 44 * scale factor of 2)
    64240 (MSS x 44)
    bandwidth * delay product:
    Your RcvWindow limits you to: 58.4 kbps (7.3 KBytes/s) @ 200ms
    Your RcvWindow limits you to: 23.36 kbps (2.92 KBytes/s) @ 500ms
    Consider increasing your RWIN value to optimize TCP/IP for broadband.
    MTU Discovery (RFC1191) = ON

    Time to live left = 47 hops
    TTL value is ok.
    Timestamps (RFC1323) = OFF
    Selective Acknowledgements (RFC2018) = ON

    IP type of service field (RFC1349)= 00000000
    ------------------------------------------------------------------------------------

    Running on x.p home(o.e.m)
    512 pc133 ram
    40gb hard drive
    Using Motorola sb4100 cable modem.
     
  2. keylo

    keylo Guest

    Let XP manage your DefRcvWin... you may want to tweak your MTU a bit.... or you can set the QOS down to 1% or just 0
     
  3. flairdevil

    flairdevil Guest

    Thanks keylo.

    But how do i do that as i am still new to computers..

    Pls advise thanks..
     
  4. keylo

    keylo Guest

    ok, I think this site has atleast one of these tips, if not they can copy:rolleyes:

    I will give you 2 here:

    this ones simple:
    this is for broad band connections. I did'nt try it on dial up but might work for dial up.
    1.make sure your logged on as actually "Administrator". do not log on with any account that just has administrator priviliges.
    2. start - run - type gpedit.msc
    3. expand the "local computer policy" branch
    4. expand the "administrative templates" branch
    5. expand the "network branch"
    6. Hilight the "QoS Packet Scheduler" in left window
    7. in right window double click the "limit reservable bandwidth" setting
    8. on setting tab check the "enabled" item
    9. where it says "Bandwidth limit %" change it to read 0
    reboot if you want to but not necessary on some systems
    your all done. Effect is immediate on some systems. some need re-boot. I have one machine that needs to reboot first, the others didn't. Don't know why this is.
    This is more of a "counter what XP does" thing. In other words, XP seems to want to reserve 20% of the bandwidth for its self. Even with QoS disabled, even when this item is disabled. So why not use it to your advantage. To demonstrate the problem with this on stand alone machines start up a big download from a server with an FTP client. Try to find a server that doesn't max out your bandwidth. In this case you want a slow to medium speed server to demonstrate this. Let it run for a couple of minutes to get stable. The start up another download from the same server with another instance of your FTP client. You will notice that the available bandwidth is now being fought over and one of the clients download will be very slow or both will slow down when they should both be using the available bandwidth. Using this "tweak" both clients will have a fair share of the bandwidth and will not fight over the bandwidth.
    BROADBAND CABLE
    ==========================


    This tweak is for broad band cable connections on stand alone machines with winXP professional version - might work on Home version also. It will probably work with networked machines as well but I haven't tried it in that configuration.
    This is for winXP only, it does not work on win2000.
    In the referenced post I mentioned removing the PSched registry entry. This way however is better and gives a noticible connection speed increase. I use 3 Com cards so I don't know how it works on others at this point. I have others but I didn't test on them.It does not involve editing the registry. This tweak assumes that you have let winXP create a connection on install for your cable modem/NIC combination and that your connection has tcp/ip - QoS - file and print sharing - and client for microsoft networks , only, installed. It also assumes that winxp will detect your NIC and has in-box drivers for it. If it doesn't do not try this.
    Install the speed tweaks from the above referenced post if you want. The change this tweak makes is noticible without them.
    Before beginning:
    A. in the "My Network Pla c es" properties (right click on the desktop icon and choose properties), highlight the connection then at the menu bar choose "Advanced" then "Advanced Settings". Uncheck the two boxes in the lower half for the bindings for File and Printer sharing and Client for MS networks. Click OK
    B. Continue as indicated below
    steps:
    1. from the winXP cd in the support directory from the support cab, extract the file netcap.e x e and pla c e it in a directory on your hard drive or even in the root of your C:\ drive.
    2. next, open up a command prompt window and change directories to where you put netcap.e x e. then type "netcap/?". It will list some commands that are available for netcap and a netmon driver will be installed. At the bottom you will see your adapters. You should see two of them if using a 3Com card. One will be for LAN and the other will be for WAN something or other.
    3. Next type "netcap/Remove". This will remove the netmon driver.
    4. Open up control panel / system / dev man and look at your network adapters. You should now see two of them and one will have a yellow ! on it. Right click on the one without the yellow ! and choose uninstall. YES! you are uninstalling your network adapter, continue with the uninstall. Do not restart yet.
    5. Check your connection properties to make sure that no connection exists. If you get a wizard just cancel out of it.
    6. Now re-start the machine.
    7. After re-start go to your connection properties again and you should have a new connection called "Local area connection 2". highlight the connection then at the menu bar choose "Advanced" then "Advanced Settings". Uncheck the two boxes in the lower half for the bindings for File and Printer sharing and Client for MS networks. Click OK.
    8. Choose connection properties and uncheck the "QOS" box
    9. re- start the machine
    10 after restart enjoy the increased responsivness of IE, faster page loading, and a connection speed boost.
    Why it works:
    It seems that winXP, in its zeal to make sure every base is covered installs two seperate versions of the NIC card. One you do not normally see in any properties. Remember the "netcap/?" command above showing two different adapters? The LAN one is the one you see. The invisible one loads everything down and its like your running two separate cards together, sharing a connection among two cards. this method breaks this "bond" and allows the NIC to run un-hindered.
     
  5. entropy13

    entropy13 Guest