Internet Explorer Link Problem

Discussion in 'Windows Desktop Systems' started by Eve, May 8, 2002.

  1. Eve

    Eve Guest

    Not a very serious problem, but kinda annoying!

    For the last month or so everytime I try to click on a link in Internet Explorer it opens a new blank page. The only way I can see the page is if I right click on the link and select copy shortcut, then paste it into the address bar. This is ok, except for the odd time when for example I right click on a download link (usually downloads link will actually work normally) but sometimes even the right click method doesn't work. Any ideas on what the problem might be and how I could fix it? I don't remember doing anything odd before it this started happening, I'm hoping it might be a common fault and easy to fix *fingers crossed*:D
  2. Eve

    Eve Guest

    Had thought of that (sorry should have mentioned before) but IE doesn't show up in add/remove programs so I can't try that option. Any other ideas?
  3. Eve

    Eve Guest

    Ok, will try later, and will let you know how I get on. Thanks for your help :D
  4. stuy_b

    stuy_b Guest

    Hiya Eve, I think I found some information about your problem with IE, check this...;en-us;Q281679
  5. walkabout

    walkabout OSNN Renegade

    Gold Coast, Australia
    Repairing IE6 in XP Pro

    Hi Eve,
    To find a way to repair IE6 in XP go to and hit the "Win XP Tips" button on the selection down the left side of the page. From there you will find two columns in blue. your solution should be part way down the left column. Hope this helps. :)
  6. allan

    allan Guest

    Open Start
    Then type: regsvr32 urlmon.dll
    Press Enter.
  7. Eve

    Eve Guest

    Thanks Allan, you're a star! I have absolutely no idea how it worked, but it did and that's what counts. Thanks again! :D