Installing a Belkin 4-port USB card

Discussion in 'General Hardware' started by pntgrd, Dec 27, 2001.

  1. pntgrd

    pntgrd Guest

    I am trying to get a Belkin USB pci addon card to work to take the place of the piece of crap Via usb controller on my m/b. The card itself installs just fine, no conflicts with anything. Problem is it will not recognize any usb device that is plugged into it. I have tried all I know and all I could glean from USBMan's site to no avail. I am still screwed and stuck with the Via controller. Has anyone solved this problem?
  2. shaan247

    shaan247 Guest

    Don't have an answer to the above question - sorry - but this is still related.....

    I've got a 4 port USB card ( a generic one - not a Belkin one as before ) and everytime I slot it into a PCI slot in my machine and boot up I just get a blank screen. USB is enabled in the bios.

    It's an AMD K6-2 450 running Windows XP. Uses an old ALI AT super-socket 7 mo'bo'. Any ideas??? The board doesn't have USB ports of it's own. Tested all the PCI slots with other devices and all seemed okay. Card works in another machine okay.

    Plz help!!!!!

  3. pntgrd

    pntgrd Guest

    I can't help with yours but I did get mine fixed. As per instructions by Bill D. at, I disabled ACPI in bios and did a reinstall of XP (repair install). I put the pci card in slot 4 and assigned it the same irq as the onboard usb controller and XP without ACPI running gives it the same, too. And now the Belkin card works like a charm. I would suggest you go ask your question on their Q & A Forum. They do know their stuff about USB.
    Now if I could just get my internal ZIP to work off a Promise ATA66 controller card.