Icon Label Shadows

Discussion in 'Desktop Customisation' started by overlrd, Aug 29, 2002.

  1. overlrd

    overlrd Guest

    Yeah I have searched the forums (and other forums) for the answer to this one. I have searched all over the place and tried every solution I could find.

    Sometimes the drop shadows on icon labels works for my desktop icons. Then other times it will not. I have no idea how it turns off and on without me doing anything.

    I have drop shadows for icon labels enabled in the performance settings for XP. I have even tried using WindowFX and turning it on, which makes no difference. I don't have lock web items on. I have tried changing my desktop background color just for fun, and it made no difference. I have turned off cleartype, turned it back on. Nothing seems to change it.

    I am about ready to give up on it. If anyone has a solution, please tell me. Until then i'll just reboot until it randomly works one time for some reason.
     
  2. srg311

    srg311 Guest

    are you using a plain color background (no graphics: default)
    or what.

    because if you are not using a background then clear type and shadows will not show up.
     
  3. overlrd

    overlrd Guest

    Nope, I have a desktop background (not plain color). I even tried a non-web desktop based background, like a bmp. It makes no difference. I even tried disabling web content on my desktop using tweak-UI, made no difference. I am starting to think it has something to do with my display settings.

    I am running in 1920x1440x32bit, although when I ran in 1600x1200 before it did the same thing. I am going to try to play with those and reboot and see what I get. I don't know what to do anymore really.

    Last time I tried to figure it out I just gave up and disabled show desktop icons and made my own custom ones in DesktopX and added drop shadows to the labels using photoshop. I am just tired of having to do that for every icon I want to add.
     
  4. allan

    allan Guest

    Desktop Properties - Display Tab - Customize Button - Web Tab

    If there is a check in "Lock Desktop Items", remove it. If there isn't, put one in there. I think this will help.
     
  5. overlrd

    overlrd Guest

    It is working now. I enabled Lock Desktop Icons like allan said. Except now the desktop background color is what is used for all the shadows on the icons. So it doesn't really work right. :(
     
  6. overlrd

    overlrd Guest

    Basically there is no icon transparency anymore.
     
  7. allan

    allan Guest

    And "Use Drop Shadows" is still checked in Visual Effects?
     
  8. overlrd

    overlrd Guest

    Yep, it is still checked. I also figured out that WindowFX is what is adding the drop shadows when "Lock Web Items" is on. Without WindowFX there is no drop shadow on the labels and there is no icon transparency like I described.
     
  9. allan

    allan Guest

    Is WindowsFX a style program? If so, I know they cause havoc with XP's native display effects. I understand what you said in your last post, but my guess is that if there's some relationship.

    Perhaps not. Anyway, sorry I couldn't help more.
     
  10. overlrd

    overlrd Guest

    Yea it adds drop shadows to windows and you customize the desktop a bit more than normal (like turning off icon text if you want to). It is possible that it messed up some native settings, however it changes settings dependently from windows, as in once you exit WindowFX all your old settings are set back.

    Thanks for the help, I will keep messing with it, I doubt I will ever figure it out though. Oh well.
     
  11. overlrd

    overlrd Guest

    Woo okay I figured it out. Thanks for the advice on the style programs Allan. Right after that I decided to take a look at what happens when I login. At first the shadows would be there, then they would disappear. I looked at what was in my startup registry settings and behold I found the culprit. It was desktop architect, a stupid program that had some sort of tray app that ran in the background (didn't even show up in the tray).

    It is all solved now, thank you. :)
     
  12. allan

    allan Guest

    Glad our banter helped. ;)